Bug 51560 - mouse drag in X + Alt locks X
Summary: mouse drag in X + Alt locks X
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-12 11:53 UTC by Need Real Name
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-12 11:54:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-08-12 11:53:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.18-alpha1 i686; Nav)

Description of problem:
Click on backdrop and drag out a stretchy box (as if you are selecting
> some backdrop icons) now press Alt+function key. X locks up. Machine
still running, can telnet in and kill X process to recover

How reproducible:
Always

Steps to Reproduce:
1. Drag out a stretchy box on backdrop
2. Press Alt+function key
3.
	

Actual Results:  X locks

Expected Results:  X shouldn't lock :)


Additional info:

It is possible that this is a bug in gnome or sawfish.

Comment 1 Mike A. Harris 2001-08-19 23:28:14 UTC
I tested this with GNOME and KDE in Seawolf and current Rawhide, and
cannot reproduce the problem.

Comment 2 Nick Craig-Wood 2001-09-04 19:57:00 UTC
This bug affects both of my Redhat 7.1 machines.  Specifically they are running
gnome+sawfish default versions.  Alt-F1 would normally switch virtual desktops
(move to workspace 1 is what it says in the sawfish shortcuts).  However if you
press Alt-F1 while a box is dragged out on the backdrop X locks up solid.

Detailed instructions.  Click and hold mouse button 1 on backdrop - drag a box
not selecting anything.  Keep holding button 1 down - dotted box stays on the
screen.  Now press Alt-F1 (while button 1 is held down) - lockup.

It is the action of switching virtual desktops while a dotted box is drawn that
crashes X.

This happens on a machine with an ATI card and a machine with a Matrox graphics
card.


Note You need to log in before you can comment on or make changes to this bug.