Bug 515689 - libvirt should allow PCI PM reset on multi-function devices
libvirt should allow PCI PM reset on multi-function devices
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12VirtTarget
  Show dependency treegraph
 
Reported: 2009-08-05 07:56 EDT by Mark McLoughlin
Modified: 2009-09-04 00:09 EDT (History)
7 users (show)

See Also:
Fixed In Version: 0.6.2-17.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-04 00:09:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2009-08-05 07:56:52 EDT
This code is wrong:

    /* For now, we just refuse to do a power management reset
     * if there are other functions on this device.                     
     * In future, we could allow it so long as those functions                    
     * are not in use by the host or other guests. 
     */
    if (pciDeviceContainsOtherFunctions(conn, dev)) {
        VIR_WARN("%s contains other functions, not resetting", dev->name);
        return -1;
    }

It turns out that PM reset does not affect other functions on a mutli-function device.
Comment 1 Mark McLoughlin 2009-08-14 03:34:06 EDT
Patch committed upstream:

  http://libvirt.org/git/?p=libvirt.git;a=commitdiff;h=64a6682b93
Comment 2 Fedora Update System 2009-08-19 12:34:58 EDT
libvirt-0.6.2-16.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libvirt-0.6.2-16.fc11
Comment 3 Fedora Update System 2009-08-20 16:58:17 EDT
libvirt-0.6.2-17.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libvirt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8790
Comment 4 Fedora Update System 2009-09-04 00:09:18 EDT
libvirt-0.6.2-17.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.