This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 515694 - RFE: Support disk I/O bandwidth limitation / priority control
RFE: Support disk I/O bandwidth limitation / priority control
Status: CLOSED DUPLICATE of bug 632492
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Jiri Denemark
Virtualization Bugs
: FutureFeature
: 598438 (view as bug list)
Depends On:
Blocks: 519868 554544 575275 Rhel6.1LibvirtTier2
  Show dependency treegraph
 
Reported: 2009-08-05 08:25 EDT by Daniel Berrange
Modified: 2011-03-09 04:20 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-23 16:06:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2009-08-05 08:25:24 EDT
Description of problem:
There needs to be a mechanism to enforce disk I/O bandwidth for guest virtual machines. For the QEMU driver, this could be done using the CLONE_IO flag & io priority schedular tunable. CGroups may also soon gain a block IO controller that could be used.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 RHEL Product and Program Management 2009-08-05 08:49:56 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Daniel Veillard 2009-10-08 08:34:50 EDT
No work has been done upstream about this, and this requires a new API and
much testing, this is IMHO really at risk at this point so Cond NACK on 
Upstream,

Daniel
Comment 5 Vivek Goyal 2010-02-16 10:20:51 EST
The basic weight based proportional BW division IO controller (blkio) patches went upstream (available in current 2.6.33-rc8) and are also available in RHEL6 kernel. It would be good if we can have some kind of support for it in libvirt.

A quick HOWTO is available in kernel sources. Documentation/cgroups/blkio-controller.txt.

Alternatively, one can find it here.

http://www.linuxhq.com/kernel/v2.6/32-git15/Documentation/cgroups/blkio-controller.txt
Comment 6 Daniel Berrange 2010-06-01 08:12:58 EDT
*** Bug 598438 has been marked as a duplicate of this bug. ***
Comment 8 Dave Allan 2010-11-23 16:06:28 EST

*** This bug has been marked as a duplicate of bug 632492 ***

Note You need to log in before you can comment on or make changes to this bug.