Bug 515696 - RFE: Support network I/O bandwidth controls
RFE: Support network I/O bandwidth controls
Status: CLOSED DUPLICATE of bug 632760
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Jiri Denemark
Virtualization Bugs
: FutureFeature
: 598437 (view as bug list)
Depends On:
Blocks: 519868 554544 575275
  Show dependency treegraph
 
Reported: 2009-08-05 08:27 EDT by Daniel Berrange
Modified: 2010-11-23 16:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-23 16:07:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2009-08-05 08:27:52 EDT
Description of problem:
There needs to be a way to control network bandwidth usage of guest virtual machines. There is a CGroup controller that can bind to the  'tc' classifier that could be used to control QEMU guests.  Xen also has a tunable for VIFs that can be set

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 RHEL Product and Program Management 2009-08-05 08:49:48 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Daniel Veillard 2009-10-08 08:35:50 EDT
No work has been done upstream about this, and this requires a new API and
much testing, this is IMHO really at risk at this point so Cond NACK on
Upstream,

Daniel
Comment 5 Daniel Berrange 2010-06-01 08:07:52 EDT
*** Bug 598437 has been marked as a duplicate of this bug. ***
Comment 7 Dave Allan 2010-11-23 16:07:46 EST

*** This bug has been marked as a duplicate of bug 632760 ***

Note You need to log in before you can comment on or make changes to this bug.