Bug 515797 - smoltSendProfile traceback
Summary: smoltSendProfile traceback
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: python-urlgrabber
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: James Antill
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 517756 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-05 18:47 UTC by Jerry Amundson
Modified: 2014-01-21 23:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-13 15:46:38 UTC


Attachments (Terms of Use)

Description Jerry Amundson 2009-08-05 18:47:43 UTC
Description of problem:
smoltSendProfile traceback

Version-Release number of selected component (if applicable):
smolt-1.3-2.fc12.noarch

How reproducible:
always

[root@jerry-D600o ~]# smoltSendProfile 
        UUID: af8d7cad-14e3-4a96-bfc6-5c11c6aa628c
        OS: Fedora release 11.90 (Rawhide)
        Default run level: 5
        Language: en_US.UTF-8
        Platform: i686
        BogoMIPS: 3987.34
        CPU Vendor: GenuineIntel
        CPU Model: Intel(R) Pentium(R) M processor 2.00GHz
        CPU Stepping: 6
        CPU Family: 6
        CPU Model Num: 13
        Number of CPUs: 1
        CPU Speed: 2000
        System Memory: 988
        System Swap: 2015
        Vendor: Dell Computer Corporation
        System: Latitude D600
        Form factor: laptop
        Kernel: 2.6.31-0.125.rc5.git2.fc12.i686
        SELinux Enabled: 1
        SELinux Policy: targeted
        SELinux Enforce: Enforcing

                 Devices
                =================================
                (None:None:None:None) ppdev, Unknown, None, Parallel Port Device
                (None:None:None:None) drm, Unknown, None, Direct Rendering Manager Device
                (None:None:None:None) input, Unknown, None, AlpsPS/2 ALPS DualPoint TouchPad
                (None:None:None:None) scsi_generic, Unknown, None, SCSI Generic Interface
                (None:None:None:None) scsi_host, Unknown, None, SCSI Host Adapter
                (None:None:None:None) scsi_host, Unknown, None, SCSI Host Adapter
                (4631:28947:4136:285) pci, yenta_cardbus, SOCKET, OZ711EC1 SmartCardBus Controller
                (None:None:None:None) pnp, rtc_cmos, None, AT Real-Time Clock
                (32902:9415:32902:17729) pci, uhci_hcd, USB, 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3
                (4098:19558:4136:285) pci, radeon, VIDEO, Radeon RV250 [Mobility FireGL 9000]
                (None:None:None:None) pnp, serial, None, 16550A-compatible COM port
                (None:None:None:None) pnp, i8042 aux, None, PS/2 Port for PS/2-style Mice
                (None:None:None:None) scsi, sd, None, SCSI Device
                (None:None:None:None) pcmcia, Unknown, None, SmartCardBus Reader
                (32902:9421:4136:285) pci, ehci_hcd, USB, 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller
                (32902:13121:0:0) pci, Unknown, OTHER, 82855PM Processor to AGP Controller
                (32902:13120:0:0) pci, agpgart-intel, OTHER, 82855PM Processor to I/O Controller
                (4631:28947:4136:285) pci, yenta_cardbus, SOCKET, OZ711EC1 SmartCardBus Controller
                (None:None:None:None) power_supply, Unknown, None, DELL 4M010
                (32902:16928:32902:10017) pci, Unknown, NETWORK, PRO/Wireless 2200BG [Calexico2] Network Connection
                (32902:9288:0:0) pci, Unknown, OTHER, 82801 Mobile PCI Bridge
                (None:None:None:None) platform, Unknown, None, Platform Device (vesafb.0)
                (None:None:None:None) serio, psmouse, None, i8042 AUX port
                (None:None:None:None) scsi_generic, Unknown, None, SCSI Generic Interface
                (None:None:None:None) scsi_host, Unknown, None, SCSI Host Adapter
                (None:None:None:None) scsi, sr, None, SCSI Device
                (None:None:None:None) pnp, parport_pc, None, ECP printer port
                (None:None:None:None) drm, Unknown, None, Direct Rendering Manager Device
                (None:None:None:None) platform, Unknown, None, Platform Device (dock.0)
                (None:None:None:None) drm, Unknown, None, Direct Rendering Manager Device
                (None:None:None:None) net, Unknown, NETWORK, Loopback device Interface
                (5348:5725:4136:34397) pci, tg3, NETWORK, NetXtreme BCM5705M Gigabit Ethernet
                (None:None:None:None) power_supply, Unknown, None, Generic AC Adapter Device
                (None:None:None:None) platform, i8042, None, Platform Device (i8042)
                (None:None:None:None) platform, Unknown, None, Platform Device (pcspkr)
                (None:None:None:None) platform, iTCO_wdt, None, Platform Device (iTCO_wdt)
                (32902:9420:0:0) pci, Unknown, OTHER, 82801DBM (ICH4-M) LPC Interface Bridge
                (32902:9418:32902:17729) pci, ata_piix, IDE, 82801DBM (ICH4-M) IDE Controller
                (None:None:None:None) platform, dcdbas, None, Platform Device (dcdbas)
                (None:None:None:None) drm, Unknown, None, Direct Rendering Manager Device
                (None:None:None:None) net, Unknown, NETWORK, Networking Interface
                (None:None:None:None) drm, Unknown, None, Direct Rendering Manager Device
                (32902:9410:32902:17729) pci, uhci_hcd, USB, 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1
                (None:None:None:None) scsi_host, Unknown, None, SCSI Host Adapter
                (32902:9414:5361:21538) pci, Intel ICH Modem, MODEM, 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller
                (32902:9412:32902:17729) pci, uhci_hcd, USB, 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2
                (32902:9413:4136:285) pci, Intel ICH, AUDIO, 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller
                (None:None:None:None) scsi_host, Unknown, None, SCSI Host Adapter
                (None:None:None:None) pnp, i8042 kbd, None, IBM Enhanced (101/102-key, PS/2 mouse support)
                (None:None:None:None) input, Unknown, None, Video Bus
                (None:None:None:None) input, Unknown, None, DualPoint Stick
                (None:None:None:None) input, Unknown, None, Lid Switch
                (None:None:None:None) input, Unknown, MOUSE, Macintosh mouse button emulation
                (None:None:None:None) input, Unknown, None, Sleep Button
                (None:None:None:None) input, Unknown, None, Power Button
                (None:None:None:None) platform, Unknown, None, Platform Device (Fixed MDIO bus.0)
                (None:None:None:None) platform, serial8250, None, Platform Device (serial8250)
                (None:None:None:None) serio, atkbd, None, i8042 KBD port
                (None:None:None:None) input, Unknown, KEYBOARD, AT Translated Set 2 keyboard
                (5117:2113:None:None) usb, usb-storage, OTHER, USB Mass Storage Interface
                (None:None:None:None) scsi_host, Unknown, None, SCSI Host Adapter
                (None:None:None:None) scsi_generic, Unknown, None, SCSI Generic Interface
                (None:None:None:None) scsi, sr, None, SCSI Device

        Filesystem Information
                device mtpt type bsize frsize blocks bfree bavail file ffree favail
                ===================================================================
                /dev/root / ext4 4096 4096 2360154 1690339 1666380 606208 493493 493493
                /dev/sda1 /boot ext3 1024 1024 194442 143407 133368 50200 50153 50153
                /dev/mapper/vg_jerryd600o-LogVol02 /home ext4 4096 4096 6694671 6416009 6075939 1700608 1700360 1700360


Send this information to the Smolt server? (y/n) y
Traceback (most recent call last):
  File "/usr/bin/smoltSendProfile", line 196, in <module>
    proxies=proxies)
  File "/usr/share/smolt/client/smolt.py", line 564, in send
    ('Content-type', 'application/x-www-form-urlencoded')))
  File "/usr/lib/python2.6/site-packages/urlgrabber/grabber.py", line 954, in urlopen
    return self._retry(opts, retryfunc, url)
  File "/usr/lib/python2.6/site-packages/urlgrabber/grabber.py", line 914, in _retry
    r = apply(func, (opts,) + args, {})
  File "/usr/lib/python2.6/site-packages/urlgrabber/grabber.py", line 953, in retryfunc
    return PyCurlFileObject(url, filename=None, opts=opts)
  File "/usr/lib/python2.6/site-packages/urlgrabber/grabber.py", line 1464, in __init__
    self._do_open()
  File "/usr/lib/python2.6/site-packages/urlgrabber/grabber.py", line 1629, in _do_open
    self._set_opts()
  File "/usr/lib/python2.6/site-packages/urlgrabber/grabber.py", line 1592, in _set_opts
    self.curl_obj.setopt(pycurl.POSTFIELDS, opts.data)
TypeError: invalid arguments to setopt
[root@jerry-D600o ~]#

Comment 1 Ville Skyttä 2009-08-13 09:02:46 UTC
Could be a python-urlgrabber issue, Ccing maintainers.

Comment 2 seth vidal 2009-08-13 13:01:52 UTC
definitely is a python-urlgrabber issue. I'll give it some tests.

Comment 3 seth vidal 2009-08-13 15:19:50 UTC
okay - the postdata being passed in here is a unicode object, not a string object. Pycurl appears to be very picky about that. I've got a question out now as to if this is a pycurl issue and/or if there is another workaround.

If push comes to shove we can coerce it into the right type and catch the problems that may occur from there.

But this is definitely a urlgrabber issue - not smolt's fault.

Comment 4 seth vidal 2009-08-13 15:46:38 UTC
okay - fixed upstream. Next version of urlgrabber will have this fix in it.

Comment 5 Mike McGrath 2009-08-17 16:07:39 UTC
*** Bug 517756 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.