Bug 515824 - Broken X/Nvidia after kernel update
Broken X/Nvidia after kernel update
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kpackagekit (Show other bugs)
11
All Linux
low Severity urgent
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-05 16:27 EDT by Brendon
Modified: 2009-08-19 16:13 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-05 16:49:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brendon 2009-08-05 16:27:35 EDT
Description of problem:

After a kernel update is applied and the system is restarted, X fails to load, due to incorrect nvidia kernel module, which does not seem to track the installed kernel version like fedora 10. 
Version-Release number of selected component (if applicable):


How reproducible:

Every kernel update so far.

Steps to Reproduce:
1. Install f11
2. Install kmod or akmod nvidia driver
3. update kernel and reboot
  
Actual results:

No X no login no desktop

Expected results:

updated kernel and nvidia module and usual desktop computing

Additional info:

same effect on 32 and 64bit installations
Comment 1 Rex Dieter 2009-08-05 16:34:04 EDT
I'd suggest you take this up with the distributor of said kmod or akmod packages... not sure if there's anything we can do about that here (esp in kpackagekit).
Comment 2 Kevin Kofler 2009-08-05 16:49:34 EDT
You hit the time window between the kernel update and the corresponding kmod update. There's nothing we can do about this in kpackagekit or any other updater.
Comment 3 Brendon 2009-08-19 15:28:17 EDT
I understand the political response you provided, but 'notabug' and 'wontfix' doesn't cut it in the real world, its the kernel update that breaks the system not the proprietary kernel module.

So for all NVIDIA users who would like to use 3D acceleration and Fedora using the 'akmod' package from RPMfusion seem to alleviate the compatibility issues.

To install the nvidia akmod package issue the following command, and reboot your system;

su -c 'yum install akmod-nvidia'
Comment 4 Kevin Kofler 2009-08-19 16:13:43 EDT
This doesn't change the fact that it's not a bug in KPackageKit (nor PackageKit, nor yum, nor anything else really), they're all working as designed.

Yes, using the akmod can work around it. Or just use your brain before applying a kernel update (wait for the kmods to be updated).

> its the kernel update that breaks the system not the proprietary kernel module

No, it's the fact that it's impossible for 2 separate repositories handled by separate administrators and mirrored over separate mirroring infrastructures with unpredictable delays to be perfectly in synchrony which is breaking your system. It's your job as the user to wait for the kmods to be out before upgrading the kernel, there's nothing the kernel maintainers or even the kmod-nvidia maintainers at RPM Fusion can do about this.

Note You need to log in before you can comment on or make changes to this bug.