Bug 5159 - Should '*.info' include mark messages
Should '*.info' include mark messages
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: sysklogd (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-09-15 11:42 EDT by james-mathiesen
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-17 18:17:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description james-mathiesen 1999-09-15 11:42:27 EDT
After installing sysklogd-1.3.31-0.5 on RedHat 5.2 we began
receiving -- MARK -- messages in /var/adm/messages.  Our
syslog.conf contains:

	*.info		/var/adm/messages

The sysklogd doc isn't explicit on wether '*' includes mark
messages or not, but my previous experience was that it did
not.  The solaris man page on syslog.conf(4) is an example
of an implementation that does not include mark messages in
the definition of '*'.

The line in syslogd.c:

	if (*buf == '*') {
           for (i = 0; i <= LOG_NFACILITIES; i++) {

Can be changed to '< LOG_NFACILITIES' to stop including
mark messages by default (since mark is the last facility
added after all the real facilities)

I suspect the correct behavior is not to include -- MARK --
messages.  In any case I would suggest clarifying doc on
a few points:

* Inclusion or non-inclusion of mark in '*' be explicitly
  stated.

* Mentioning that mark messages are generated at the 'info'
  priority level.

* Mentioning that mark messages only appear when there has
  not been other recent output to a target.
Comment 1 Bill Nottingham 1999-09-17 18:17:59 EDT
You can simply run syslogd with the '-m 0' option to turn
off mark messages.

Note You need to log in before you can comment on or make changes to this bug.