Bug 516042 - Unable to add NFS yum repo during installation
Summary: Unable to add NFS yum repo during installation
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Radek Vykydal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: NeedsRetesting
Depends On: 524599
Blocks: F12Beta, F12BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2009-08-06 14:14 UTC by Kamil Páral
Modified: 2009-10-05 12:51 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-05 12:51:38 UTC
Type: ---


Attachments (Terms of Use)
bug demonstration (566.28 KB, video/ogg)
2009-08-06 14:14 UTC, Kamil Páral
no flags Details
logs.tar.gz (29.17 KB, application/x-gzip)
2009-08-06 14:15 UTC, Kamil Páral
no flags Details
dump.txt (190.49 KB, text/plain)
2009-09-07 12:46 UTC, Kamil Páral
no flags Details
gui error (106.90 KB, image/png)
2009-10-05 12:16 UTC, Kamil Páral
no flags Details
console error (15.72 KB, image/png)
2009-10-05 12:17 UTC, Kamil Páral
no flags Details
logs (27.53 KB, application/x-gzip)
2009-10-05 12:17 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2009-08-06 14:14:51 UTC
Created attachment 356519 [details]
bug demonstration

Description of problem:
I'm installing Fedora 12 Alpha TC:
http://alt.fedoraproject.org/pub/alt/stage/12-Alpha-TC/Fedora-12-Alpha-x86_64-DVD/
from DVD in virt-manager (using KVM).

When trying to install from NFS, I select "modify repository", choose NFS, fill details and click OK. An error message pops up that repomd.xml can't be retrieved (see video). But the NFS *is* mounted in /mnt/source and repomd.xml *is* available.
 
Version-Release number of selected component (if applicable):
* anaconda-12.7
* virt host - Fedora 11, libvirt-0.6.2-13.fc11.x86_64

How reproducible:
so far always

Steps to Reproduce:
1. Boot from F12 Alpha TC DVD
2. Select NFS install and select path
3. See error
  
Actual results:
Can't find repository

Expected results:
Can find repository

Additional info:
See attached logs and video

Comment 1 Kamil Páral 2009-08-06 14:15:22 UTC
Created attachment 356520 [details]
logs.tar.gz

Comment 2 Kamil Páral 2009-08-06 14:26:33 UTC
Slight change: I have installed from netinst image instead of DVD. But I think it doesn't matter.

Comment 3 David Pravec 2009-08-06 15:13:10 UTC
i have also seen this bug using install DVD of Fedora 12 Alpha.

Comment 4 James Laska 2009-08-07 19:52:17 UTC
Reviewed during F-12-Alpha Blocker bug meeting.  Modifying yum repositories during installation will be discouraged for the Alpha in favor of performing any yum repo operations in the post-installation environment.

Ideally, one can perform a NFS installation when booting the boot.iso or DVD with the boot argument: "askmethod"  However, that appears to be inoperable for F-12-Alpha (see bug#515450).  To perform a NFS installation, it is recommended that you install from a PXE server or using the media-less instructions (see http://docs.fedoraproject.org/install-guide/f11/en-US/html/ap-medialess-install.html).

Adjusting the title of this defect to match the failure case.

Comment 5 David Pravec 2009-08-07 19:56:14 UTC
i have tried boot (anaconda) option:
   repo=nfs:<server>[:options]:/<path>
which failed.

I checked that the nfs mountpoint is correct, and yes, it contais repodata/repomd.xml

Comment 6 James Laska 2009-08-07 20:07:32 UTC
(In reply to comment #5)
> i have tried boot (anaconda) option:
>    repo=nfs:<server>[:options]:/<path>
> which failed.

It appears that due to bug#515450 ... no matter what you boot a boot.iso or DVD with, it will continue with using the install.img on that media (instead of the method= or repo= parameters).  To perform a NFS installation, you may need to try the steps outlined in comment#4. 

If that fails, there may be a new issue lurking worthy of a new bug report.  This bug report will track the REPO edit behavior noted in the attached screencast (see attachment#356519 [details]).

Comment 7 Chris Lumens 2009-08-19 14:31:18 UTC
This should be fixed in anaconda-12.17.

Comment 8 Kamil Páral 2009-09-07 12:46:44 UTC
Created attachment 359991 [details]
dump.txt

This is not fixed. In Anaconda 12.20 after modifying default repo with NFS values I get this error:

anaconda 12.20 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/yum/config.py", line 93, in __set__
    raise ValueError('Error parsing %r: %s' % (value, str(e)))
  File "/usr/lib/anaconda/iw/task_gui.py", line 323, in _applyNfs
    repo.baseurl = "file://%s" % dest
  File "/usr/lib/anaconda/iw/task_gui.py", line 357, in run
    if not applyFuncs[type](newRepoObj) or not self._enableRepo(newRepoObj) or not \
  File "/usr/lib/anaconda/iw/task_gui.py", line 511, in _editRepo
    dialog.run()
ValueError: Error parsing 'file:///mnt/Fedora - Rawhide - Developmental packages for the next Fedora releasec3ImxN': URL must be http, ftp, file or https not ""

Local variables in innermost frame:
obj: rawhide
self: <yum.config.UrlListOption object at 0x7f70f9b4fed0>
e: URL must be http, ftp, file or https not ""
value: file:///mnt/Fedora - Rawhide - Developmental packages for the next Fedora releasec3ImxN

Comment 9 Radek Vykydal 2009-09-07 13:23:30 UTC
I am working on repo editing dialog.
Does updates file
http://rvykydal.fedorapeople.org/updates.repo.img
fix the problem for you? In my tests it does.

Comment 10 Kamil Páral 2009-09-07 14:05:28 UTC
Yes Radek, that does solve the problem.

Comment 11 John Poelstra 2009-09-11 15:17:46 UTC
This bug was reviewed at the Fedora 12 Beta Blocker bug meeting on 2009-09-11.
< denise> jlaska, rvykydal says he just sent patches for review for 516042

Comment 12 Radek Vykydal 2009-09-14 10:47:54 UTC
If I remember it well, this traceback should be handled by [1/14] of my patchset
https://www.redhat.com/archives/anaconda-devel-list/2009-September/msg00146.html,
though this fix of the traceback from comment #8 may just show another error fixed by some of following patches.

Comment 13 Radek Vykydal 2009-09-15 09:17:43 UTC
The traceback from comment #8 should be fixed in version 12.25 of anaconda.

Comment 14 John Poelstra 2009-09-18 15:16:43 UTC
This bug was reviewed at the Fedora 12 Beta Blocker bug meeting on 2009-09-18.  It needs to be retested.  Please help us by reporting if the latest package addresses the originally reported issue.  Thanks.

Comment 15 Kamil Páral 2009-09-21 12:55:53 UTC
I would love to verify the fix but everytime there comes another issue that prevents that. This time it is blocked for me because of bug #524599.

Comment 16 Radek Vykydal 2009-09-29 08:16:51 UTC
Kamil, I think it is possible to verify this bug with version 12.29 of anaconda present in Sep 24 rawhide. See
https://bugzilla.redhat.com/show_bug.cgi?id=524599#c5.
Concerning the bug #524599, I am going to push patches that should go into anaconda 12.32.

Comment 17 Kamil Páral 2009-09-29 11:31:06 UTC
I tried anaconda 12.31 and basic functionality is ok, but the dialogs are so broken that I don't know whether to report it here again or create new bugs :) I will wait until 12.32 is out (tomorrow I guess) and provide a feedback then, it could solve at least one more dialog problem.

Comment 18 Radek Vykydal 2009-09-29 12:53:04 UTC
Yep, I know, the dialogs are very broken. I have some more patches going through review right now, could you please create separate bugs for issues you are hitting (with 12.32) and use this bug just for case from description, i.e. confirm if it is fixed in 12.31/32? Thanks for patience.

Comment 19 James Laska 2009-10-02 19:04:17 UTC
Testing with anaconda-12.32.  I booted the rawhide-i386/boot.iso and was able to add an NFS yum repository (ntap-curly.corp.redhat.com:/vol/fedora/rawhide/nightly/rawhide-20091002/i386/os) without error.  I was also able to continue the install to package selection and boot the installed system.  Marking this issue as CLOSED RAWHIDE.

However, it sounds like there make be additional bugs lurking based on feedback from Kamil (comment#17).  Please file any new bugs to track any additional failures observed.  Thanks!

Comment 20 Kamil Páral 2009-10-05 12:16:57 UTC
Created attachment 363659 [details]
gui error

I'm sorry. It doesn't work.

Anaconda 12.32, can't mount NFS even in shell now. See attachments.

Comment 21 Kamil Páral 2009-10-05 12:17:17 UTC
Created attachment 363660 [details]
console error

Comment 22 Kamil Páral 2009-10-05 12:17:35 UTC
Created attachment 363661 [details]
logs

Comment 23 Kamil Páral 2009-10-05 12:27:45 UTC
Maybe it's worth mentioning that I had no problems mounting NFS in anaconda 12.31.

Comment 24 Chris Lumens 2009-10-05 12:51:38 UTC
This is unrelated.  The error in comment #22 is because you need to add -o nolock, which anaconda adds automatically.  If you are seeing a different bug from the original one in this report, please open a new report.  Thanks.


Note You need to log in before you can comment on or make changes to this bug.