Bug 516050 - package-cleanup falls down into infinite recursion if yum-versionlock.list is non-empty
package-cleanup falls down into infinite recursion if yum-versionlock.list is...
Status: CLOSED DUPLICATE of bug 485578
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-06 10:30 EDT by Ilya Ryabinkin
Modified: 2014-01-21 18:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-06 15:58:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Full trace of package-cleanup error (128.13 KB, text/plain)
2009-08-06 10:30 EDT, Ilya Ryabinkin
no flags Details

  None (edit)
Description Ilya Ryabinkin 2009-08-06 10:30:59 EDT
Created attachment 356523 [details]
Full trace of package-cleanup error

Description of problem:

package-cleanup --leaves --all crashed if yum-versionlock.list contains at least one locked package.


Version-Release number of selected component (if applicable):
yum-utils-1.1.22-1.fc10

How reproducible:
Always

Steps to Reproduce:
1. Lock package(s)
2. run package-cleanup (see example in Description)

  
Actual results:
RuntimeError: maximum recursion depth exceeded

Expected results:
List of rpm leaves 

Additional info:
Full trace is attached
Comment 1 seth vidal 2009-08-06 15:58:14 EDT

*** This bug has been marked as a duplicate of bug 485578 ***

Note You need to log in before you can comment on or make changes to this bug.