Bug 51616 - Hard disk upgrade requires disk to be FAT filesystem
Hard disk upgrade requires disk to be FAT filesystem
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Brock Organ
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-08-12 23:03 EDT by Need Real Name
Modified: 2007-04-18 12:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-08-20 10:26:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-08-12 23:03:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.4.8 i686)

Description of problem:
When attempting to upgrade my Multia, I found that not only does it now
require the ISO images, but it requires the filesystem to be a FAT
filesystem (ONLY).  This doesn't work when the ISO images reside on an ext2

How reproducible:

Steps to Reproduce:
1. Place ISO images on an ext2 filesystem
2. Boot rh71 and choose hard-disk install
3. Attempt to use the filesystem that contains the ISO images

Actual Results:  Alt-F4 shows that "The filesystem does not contain a valid
VFAT filesystem"

Expected Results:  It should have mounted the filesystem with 'mount' and
let it figure out what kind of filesystem it is.  In lieu of that (I know
it uses the mount syscall() directly), it should at least attempt the other
common filesystem types.

Additional info:
Comment 1 Brent Fox 2001-08-13 11:18:37 EDT
I tried a hard drive upgrade from an ext2 partition on an i386 box just the
other day, and it went fine.  

Bryce, have you tried this on any of your Alphas?  I can't imagine that this
could be a platform specific issue, but you never know.
Comment 2 Phil Copeland 2001-08-13 17:57:33 EDT
No idea....
I've never done an ISO HD install. Best person to ask would be Broock
Comment 3 Matt Wilson 2001-08-20 10:26:20 EDT
we don't have the luxary of the normal "mount" command, we call the syscall
directly.  We use the partition type (0x83, 0xe, etc) to determine the
filesystem to attempt to mount as.  Is the type on the partition 0x83 (or 0x8
for BSD disklabel)
Comment 4 Brent Fox 2001-09-19 14:57:22 EDT
Closing due to inactivity.  Please reopen if you have more information.

Note You need to log in before you can comment on or make changes to this bug.