Bug 516162 - gnome doesn't start
gnome doesn't start
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Reopened
: 516161 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-07 00:56 EDT by David Tardon
Modified: 2009-10-16 04:23 EDT (History)
5 users (show)

See Also:
Fixed In Version: 1.7.0-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-16 04:23:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg.log of the crashed session (81.02 KB, text/plain)
2009-08-07 00:56 EDT, David Tardon
no flags Details
/var/log/messages (4.01 MB, text/plain)
2009-08-07 03:27 EDT, David Tardon
no flags Details
/var/log/dmesg (40.50 KB, text/plain)
2009-08-08 03:12 EDT, David Tardon
no flags Details
xorg.conf (844 bytes, text/plain)
2009-08-10 01:09 EDT, David Tardon
no flags Details
/var/log/Xorg.0.log (58.13 KB, text/plain)
2009-08-10 05:40 EDT, David Tardon
no flags Details

  None (edit)
Description David Tardon 2009-08-07 00:56:25 EDT
Created attachment 356621 [details]
Xorg.log of the crashed session

Description of problem:
A try to start gnome causes crash of X server and return to login screen.

Version-Release number of selected component (if applicable):
gnome-session-2.27.5-1.fc12.x86_64

How reproducible:
always

Steps to Reproduce:
1. select your login and enter password
2. select Gnome as session
3. press Login
  
Actual results:
return to the login screen

Expected results:
running gnome

Additional info:
kernel-2.6.31-0.125.rc5.git2.fc12.x86_64
xorg-x11-server-Xorg-1.6.99-27.20090804.fc12.x86_64
xorg-x11-drv-ati-6.12.2-21.fc12.x86_64
Comment 1 David Tardon 2009-08-07 03:27:36 EDT
Created attachment 356624 [details]
/var/log/messages
Comment 2 Matthias Clasen 2009-08-07 13:56:19 EDT
An X server segfault is automatically X's fault.
Comment 3 Matěj Cepl 2009-08-07 19:59:00 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available), /var/log/dmesg, and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 David Tardon 2009-08-08 03:12:41 EDT
Created attachment 356752 [details]
/var/log/dmesg
Comment 5 Matěj Cepl 2009-08-09 11:07:11 EDT
Could you still reproduce the bug even after relabelling your disk?
Comment 6 David Tardon 2009-08-10 00:14:37 EDT
dtardon->mcepl: No, it's OK now.
Comment 7 David Tardon 2009-08-10 01:08:39 EDT
dtardon->mcepl: Taking back comment 6: it still crashes when run without xorg.conf. However, it doesn't crash with the following xorg.conf.
Comment 8 David Tardon 2009-08-10 01:09:21 EDT
Created attachment 356847 [details]
xorg.conf
Comment 9 David Tardon 2009-08-10 05:40:09 EDT
Created attachment 356863 [details]
/var/log/Xorg.0.log
Comment 10 Matěj Cepl 2009-08-10 06:46:28 EDT

*** This bug has been marked as a duplicate of bug 515074 ***
Comment 11 Matěj Cepl 2009-08-10 07:08:57 EDT
*** Bug 516161 has been marked as a duplicate of this bug. ***
Comment 12 David Tardon 2009-09-09 09:44:31 EDT
Reopening. The bug this one was made duplicate of is, according to comments, fixed in xorg-x11-server-Xorg-1.6.99-28, but X still crashes on my machine with xorg-x11-server-Xorg-1.6.99-41.20090825.fc12.
Comment 13 seventhguardian 2009-10-14 18:10:36 EDT
Rawhide now features gnome-session-2.28.0-1.fc12 and xorg-x11-server-Xorg-1.7.0-1.fc12. Is this still present?

Installing X's debugging symbols and running a gdb session would be helpful.
Comment 14 David Tardon 2009-10-15 03:32:02 EDT
it works now with xorg-x11-server-Xorg-1.7.0-1.fc12 and gnome-session-2.28.0-1.fc12
Comment 15 seventhguardian 2009-10-15 03:42:20 EDT
It should be closed then, right?
Comment 16 David Tardon 2009-10-16 04:23:56 EDT
yes, it can be closed

Note You need to log in before you can comment on or make changes to this bug.