This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 51618 - building mm for sparc 6.2 dies
building mm for sparc 6.2 dies
Status: CLOSED WORKSFORME
Product: Red Hat Public Beta
Classification: Retired
Component: mm (Show other bugs)
roswell
sparc Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-13 00:58 EDT by Neil McNeight
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-13 01:04:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Neil McNeight 2001-08-13 00:58:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010725

Description of problem:
Rebuilding the mm package in order to build apache for RedHat/SPARC 6.2,
rpm dies in the install process.

How reproducible:
Always

Steps to Reproduce:
1. rpm -ba mm.spec
2.
3.
	

Actual Results:  ./shtool install -c -m 644 mm.3
/var/tmp/mm-1.1.3-root/usr/man/man3/mm.3
./shtool install -c -m 644 mm.h /var/tmp/mm-1.1.3-root/usr/include/mm.h
libtool: install: `/var/tmp/mm-1.1.3-root/usr/lib/libmm.la' is not a directory
Try `libtool --help --mode=install' for more information.
make: *** [install] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.39534 (%install)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.39534 (%install)


Expected Results:  Clean build.

Additional info:

Specifically, the problem lies in the Makefile line 170:
@$(LIBTOOL) --mode=install $(SHTOOL) install -c -m 644 libmm.la
$(libdir)/libmm.la
Comment 1 Bill Nottingham 2001-08-13 01:04:36 EDT
I believe your sparc 6.2 box will need a newer libtool.
Comment 2 Neil McNeight 2001-08-13 12:45:35 EDT
Updated to libtool-1.4-8 (as well as automake-1.4p5-1, since automake >= 1.4p1
is required to build libtool) from libtool-1.3.4. Built mm without a hitch. Thanks!

Note You need to log in before you can comment on or make changes to this bug.