Bug 516187 - libvirt should run qemu 'cont' command on successful migration finish
libvirt should run qemu 'cont' command on successful migration finish
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
11
All Linux
high Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11VirtTarget
  Show dependency treegraph
 
Reported: 2009-08-07 05:44 EDT by Mark McLoughlin
Modified: 2009-09-04 00:10 EDT (History)
6 users (show)

See Also:
Fixed In Version: 0.6.2-17.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-04 00:10:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2009-08-07 05:44:47 EDT
Chris points out that newer versions of qemu honor the -S argument with -incoming and we need to run 'cont' when the migration finishes:

  http://www.redhat.com/archives/libvir-list/2009-August/msg00142.html

Since we're updating F-11 to qemu-0.10.6, we need this in an F-11 libvirt update

We also need it in F-12 libvirt-0.7.0
Comment 1 Mark McLoughlin 2009-08-19 13:22:51 EDT
Just requested this be pushed to updates-testing:

https://admin.fedoraproject.org/updates/libvirt-0.6.2-17.fc11

* Wed Aug 19 2009 Mark McLoughlin <markmc@redhat.com> - 0.6.2-17
- Fix migration completion with newer versions of qemu (#516187)
- Fix dumpxml segfault with newer versions of Xen (#518091)
Comment 2 Fedora Update System 2009-08-20 16:58:41 EDT
libvirt-0.6.2-17.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libvirt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8790
Comment 3 Fedora Update System 2009-09-04 00:09:39 EDT
libvirt-0.6.2-17.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.