Bug 51620 - ntfs module missing from kernel and /lib/modules
ntfs module missing from kernel and /lib/modules
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-13 03:35 EDT by p929001
Modified: 2007-04-18 12:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 12:57:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description p929001 2001-08-13 03:35:24 EDT
Description of Problem: Support for NTFS filesystem seems not to be
included in the kernel (ntfs.o does not exist, mounts fail)

How Reproducible: Always

Steps to Reproduce:
1a. mount -t ntfs /dev/hda1 /mnt/win2k
1b. insmod ntfs

Actual Results:
a. mount: fs type ntfs not supported by kernel
b. insmod: ntfs: no module by that name found

Expected Results: (/mnt/win2k mounted)

Additional Information:
Using standard updated RedHat 7.1 kernel (2.4.3-12), updated by up2date.
ntfs.o is not listed as part of any recent kernel (RedHat 5.1 and up), so
it is not intended as part of the kernel? However, the Filesystems-HOWTO,
section 5.4
(http://www.europe.redhat.com/documentation/HOWTO/Filesystems-HOWTO-5.php3)
states that it is part of the official kernel.
Comment 1 Arjan van de Ven 2001-08-13 06:37:28 EDT
At the time of the 7.1 release, the NTFS driver was VERY broken. It oopsed the
kernel and also corrupted the filesystem, even in READ ONLY mode.
Comment 2 Peter Fales 2001-11-02 14:44:20 EST
Is this still true?  Could it be included in RedHat 7.2?  This is one of the
"high-runner" difficulties
in gettin Linux rolled out to more of our PC users.   Read-only access would be
better than
nothing, though I agree that not corrupting user file system is the highest
priority.

Note You need to log in before you can comment on or make changes to this bug.