Bug 51622 - Tulip-based pcmcia card has stopped working
Summary: Tulip-based pcmcia card has stopped working
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: kernel   
(Show other bugs)
Version: roswell
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-13 09:12 UTC by Julio Sanchez Fernandez
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-14 12:12:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Julio Sanchez Fernandez 2001-08-13 09:12:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [es] (X11; U; Linux 2.4.5-10 i686)

Description of problem:
Recent kernels from rawhide, but I have tested it with 2.4.6-3.1, i.e. the
one in Roswell do not support properly my card.

The last kernel rpm where it worked is 2.4.5-10 but no 2.4.6 nor 2.4.7 has
worked.

The card can be configured to up, but no traffic flows or is marginal (I
think I have succeeded in getting an IP address from DHCP, but no useful
communication happens)


How reproducible:
Always

Steps to Reproduce:
1.Boot affected kernel version
2.ifup eth0
3. or ifconfig eth0 xx.xx.xx.xx etc. up
	

Actual Results:  it runs a DHCP configuration, so ifup rarely succeeds and
times out instead.  When it works, the result is similar to that with
manual configuration: the card is up, but no traffic flows.

tcpdump does not see any traffic.  the traffic counters in ifconfig,
however show a few packets

Additional info:

For identification, lspci says:

03:00.0 Ethernet controller: Digital Equipment Corporation DECchip 21142/43
(rev 41)

and mii-tool -v says:

eth0: negotiated 100baseTx-FD, link ok
  product info: vendor 00:10:dd, model 2 rev 1
  basic mode:   autonegotiation enabled
  basic status: autonegotiation complete, link ok
  capabilities: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
  advertising:  100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
  link partner: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD

The above was taken from 2.4.5-10 (that I am running right now).

Comment 1 Arjan van de Ven 2001-08-13 11:37:08 UTC
Thank you for this useful report. The fact that 2.4.5-10 did work means that
something  (or someone) broke the driver since then. I'll check the differences
and if it's non-obvious, I'll go back to the old, working, version of the driver
for future kernels.

Comment 2 Glen Foster 2001-08-13 19:07:23 UTC
We (Red Hat) should really try to fix this before next release.

Comment 3 Julio Sanchez Fernandez 2001-11-14 12:12:37 UTC
This still seems open, but should be marked as resolved.  It is fixed in 2.4.9-13 and has been fixed for a few releases already, only I forgot to report.


Note You need to log in before you can comment on or make changes to this bug.