Bug 516274 - Keyboard does not work
Keyboard does not work
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-07 14:04 EDT by Alexey Kuznetsov
Modified: 2013-04-30 19:44 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.0.0-3.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-27 02:34:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
mini:1.log (6.09 KB, text/plain)
2009-08-10 04:56 EDT, Alexey Kuznetsov
no flags Details
mini:1.log (32.13 KB, text/plain)
2009-10-01 11:44 EDT, Alexey Kuznetsov
no flags Details
Simple example to show the bug (102 bytes, text/plain)
2009-10-14 04:56 EDT, Sascha Silbe
no flags Details

  None (edit)
Description Alexey Kuznetsov 2009-08-07 14:04:20 EDT
I have f11 installed on my ppc machine. To run vncserver i did:

vncserver -localhost -nolisten tcp -geometry 1250x700

After it i did vncview to this machine and tried to type someting in gnome-terminal on remote machine. Unforunaly i got no output, no keyboard input at all (no fn keys or other).

Also, when i did run keyboard-properies (by mouse) i got empty keyboard modes list, no layout options.. nothing...
Comment 1 Adam Tkac 2009-08-10 04:47:05 EDT
Would it be possible to attach the server log, please (located in ~/.vnc/*.log file). Thanks.
Comment 2 Alexey Kuznetsov 2009-08-10 04:56:59 EDT
Created attachment 356862 [details]
mini:1.log

yep.
Comment 3 Adam Tkac 2009-10-01 11:31:01 EDT
Are you still able to reproduce this issue? I tested fully up2date F11 powerpc and everything works fine.

If it still doesn't work in your case please append "-log *:stderr:100" to Xvnc parameters and then attach vnc log again, please.
Comment 4 Alexey Kuznetsov 2009-10-01 11:44:09 EDT
Created attachment 363363 [details]
mini:1.log

yep, problem still here.
Comment 5 Adam Tkac 2009-10-01 12:02:16 EDT
Interesting. Could you please tell me which client are you using?
Comment 6 Alexey Kuznetsov 2009-10-01 12:08:46 EDT
Sure. I tried booth, vinagre, and vncview (last one started from remote station (mini.local) with X forwarding). Same issue.

[axet@axet-laptop ~]$ ssh -X mini.local
reverse mapping checking getaddrinfo for mini.tax.local [192.168.54.3] failed - POSSIBLE BREAK-IN ATTEMPT!
Last login: Thu Oct  1 19:40:10 2009 from 192.168.54.5
[axet@mini ~]$ vncviewer localhost:1
Comment 7 Adam Tkac 2009-10-05 10:33:03 EDT
It's weird, from log it seems your server receives no key event from client.

More interesting lines are:
01/10/2009 07:41:56 PM rfbProcessClientNormalMessage: ignoring unknown encoding type 7
01/10/2009 07:41:56 PM rfbProcessClientNormalMessage: ignoring unknown encoding type -258
01/10/2009 07:41:56 PM Enabling NewFBSize protocol extension for client ::ffff:192.168.54.5
01/10/2009 07:41:56 PM rfbProcessClientNormalMessage: ignoring unknown encoding type 1464686185
01/10/2009 07:41:56 PM rfbProcessClientNormalMessage: ignoring unknown encoding type -257

It seems that you are not connecting to Xvnc but to vino server. Could you please check that you are really connecting to Xvnc? For example, when keyboard doesn't work when you start vncviewer with "localhost:1" parameter, run `netstat -apn |grep Xvnc` and check where Xvnc is listenning.

If you are connecting to vino server please go to system->preferences->remote desktop and disable it. Or simply connect to Xvnc, not to vino server.

Does keyboard work now?
Comment 8 Alexey Kuznetsov 2009-10-05 10:41:09 EDT
Yes. When i did connect to vncserver (localhost:1) i got keyboard working. But vncserver miss mdns extension, which allow to broadcast server address. I prefer to use vino.

When i did connect to vncviewer localhost:0 (vncserver) it wont to recognize my keyboard and i cant type anyting.

Same issue with OSX native VNC viewer.
Comment 9 Adam Tkac 2009-10-08 06:58:39 EDT
After inspection this is really a bug in Xvnc but it's very hard to fix. Basically it is more design bug than a code bug.

I found a temporary workaround which works:

1. connect to Xvnc with any viewer
2. press any key
3. restart vino server (make sure vino process is really restarted)
4. connect to vino server

Don't expect fix for this issue soon, it probably won't be fixed in TigerVNC 1.0 series at all, not sure yet.
Comment 10 Alexey Kuznetsov 2009-10-08 07:16:25 EDT
interesting. how can i restart vino server?
Comment 11 Adam Tkac 2009-10-08 08:06:15 EDT
1. go to preferences->remote desktop and disable it
2. check that vino-server is really down (killall vino-server, for example)
3. go to preferences->remote desktop and enable it
Comment 12 Sascha Silbe 2009-10-14 04:56:50 EDT
Created attachment 364724 [details]
Simple example to show the bug

This script fetches the keymap from the VNC server using XGetKeyboardMapping and prints the first 20 values. On a server affected by this bug the output will be all-zero.
Comment 13 Sascha Silbe 2009-10-14 05:02:38 EDT
While trying to get Sugar to run inside TigerVNC, I hit the same issue. For us the symptoms are that the hotkeys are not working because no key names can be parsed (because the keymap is empty). I've attached a small script to reproduce the issue. On RealVNC (Debian) it works fine:

[array('L', [0L, 0L]), array('L', [65307L, 0L]), array('L', [49L, 33L]), array('L', [50L, 64L]), array('L', [51L, 35L]), array('L', [52L, 36L]), array('L', [53L, 37L]), array('L', [54L, 94L]), array('L', [55L, 38L]), array('L', [56L, 42L]), array('L', [57L, 40L]), array('L', [48L, 41L]), array('L', [45L, 95L]), array('L', [61L, 43L]), array('L', [65288L, 0L]), array('L', [65289L, 0L]), array('L', [113L, 81L]), array('L', [119L, 87L]), array('L', [101L, 69L]), array('L', [114L, 82L])]

On TigerVNC (Fedora) we'll get an empty keymap until a key gets pressed:

[array('I', [0L, 0L, 0L, 0L]), array('I', [0L, 0L, 0L, 0L]), array('I', [0L, 0L, 0L, 0L]), array('I', [0L, 0L, 0L, 0L]), array('I', [0L, 0L, 0L, 0L]), array('I', [0L, 0L, 0L, 0L]), array('I', [0L, 0L, 0L, 0L]), array('I', [0L, 0L, 0L, 0L]), array('I', [0L, 0L, 0L, 0L]), array('I', [0L, 0L, 0L, 0L]), array('I', [0L, 0L, 0L, 0L]), array('I', [0L, 0L, 0L, 0L]), array('I', [0L, 0L, 0L, 0L]), array('I', [0L, 0L, 0L, 0L]), array('I', [0L, 0L, 0L, 0L]), array('I', [0L, 0L, 0L, 0L]), array('I', [0L, 0L, 0L, 0L]), array('I', [0L, 0L, 0L, 0L]), array('I', [0L, 0L, 0L, 0L]), array('I', [0L, 0L, 0L, 0L])]
Comment 14 Fedora Update System 2009-10-27 02:33:59 EDT
tigervnc-1.0.0-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2009-11-16 09:56:04 EST
tigervnc-1.0.0-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/tigervnc-1.0.0-3.fc12
Comment 16 Fedora Update System 2009-12-01 23:43:31 EST
tigervnc-1.0.0-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.