Bug 516299 - ssh slow resolving localhost
ssh slow resolving localhost
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Jan F. Chadima
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-07 17:28 EDT by Scott Wilburn
Modified: 2009-08-20 03:32 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-20 03:32:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Wilburn 2009-08-07 17:28:46 EDT
Description of problem:

ssh requires almost 5 minutes to resolve 'localhost'. Delay does not occur if hostname is given instead, or when pinging localhost.

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1. ssh localhost
2. ping localhost
3.
  
Actual results:

ping returns results immediately, ssh takes 5 minutes


Expected results:

ssh localhost is immediate

Additional info:

Contents of /etc/hosts:

127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6
Comment 1 Scott Wilburn 2009-08-07 18:58:36 EDT
A workaround is to comment out the IPV6 entry in /etc/hosts
Comment 2 Scott Wilburn 2009-08-19 23:14:51 EDT
This problem has been traced to a misconfigured ipv6tables ruleset that was blocking packets to/from localhost. It is not a bug.

Note You need to log in before you can comment on or make changes to this bug.