Bug 5163 - lpd having trouble sending job to SVR4, SVR4 not like -h
lpd having trouble sending job to SVR4, SVR4 not like -h
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: lpr (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-09-15 13:06 EDT by Tom Cross
Modified: 2014-03-16 22:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-19 12:37:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Cross 1999-09-15 13:06:56 EDT
I have a remote printer setup on my linux box which prints
to a printer on a NCR MP-RAS v3.02 (SVR4 much like UNIXWARE)
box.  When I print to that printer, I get the following love
letter from the NCR box:

Your printer job (itin.out)
could not be printed.

Reason for failure:

UX:lpd: ERROR: The following options can't be handled:
               -h
       TO FIX: The printer(s) that otherwise qualify
               for printing your request can't handle
               one or more of these options. Try
               another printer, or change the options.


I'm using lpr-0.41-2 from rawhide rebuilt on my RH 6.0
machine.  the /etc/printcap entry looks like this:


##PRINTTOOL3## REMOTE TEXT NAxNA letter {} TextPrinter
Default {}
lineptr:\
        :sd=/var/spool/lpd/lineptr:\
        :mx#0:\
        :sh:\
        :rm=landru:\
        :rp=lineptr:\
        :if=/var/spool/lpd/lineptr/filter:

As far as I can remember, this worked fine with RH 5.2 but I
don't remember which version of lpr/lpd I was using when it
worked... :(
Comment 1 Bill Nottingham 1999-09-23 15:55:59 EDT
Can you turn on DEBUG_TREE & DEBUG_FILTER in the
filter file to try and get some more information?  Thanks.
Comment 2 Tom Cross 1999-10-08 12:37:59 EDT
Changed /var/spool/lpd/lineptr/filter to define the DEBUG variables.

Printed using this command:  lpr -Plineptr /etc/issue

Filter DEBUG results:
# cat /tmp/filter.debug
Desired print format is asc
Paper size is letter
A form feed will not be sent.
Magic is |             ASCII text|
Magic is |             ASCII text|
Type of file is INPUT-to-asc
Best path of depth  is cat - | asc-to-printer.fpi


Another love letter from NCR (SVR4) box:
Your printer job (issue)
could not be printed.

Reason for failure:

UX:lpd: ERROR: The following options can't be handled:
               -h
       TO FIX: The printer(s) that otherwise qualify
               for printing your request can't handle
               one or more of these options. Try
               another printer, or change the options.
Comment 3 Tom Cross 1999-10-18 11:13:59 EDT
Just a quick note:  upgrading to lpr-0.43-2 did not help. :(

Let me know if there is anything you would like me to do...
Comment 4 Bill Nottingham 1999-10-18 12:18:59 EDT
What happens if you take the :sh: out of the printcap?
Comment 5 Tom Cross 1999-10-19 12:31:59 EDT
What happens?  Well, it works, that what happens!!  :)

Thanks much!  When printing to a SVR4 lpd printer, remove :sh:??
Works for me...
Comment 6 Bill Nottingham 1999-10-19 12:37:59 EDT
The 'sh' is the suppress headers option; apparently, when sending
that to the SVR4 lpd, it translated that into a '-h' option, which
it didn't like.

Sorry it took so long to come up with this solution.

Note You need to log in before you can comment on or make changes to this bug.