Bug 516314 - Power down of monitor occurs during active use under certain circumstances
Power down of monitor occurs during active use under certain circumstances
Status: CLOSED DUPLICATE of bug 501601
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
11
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-07 20:37 EDT by stan
Modified: 2009-08-20 08:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-20 08:31:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description stan 2009-08-07 20:37:05 EDT
Description of problem:  If the screen saver is on, and the power save is on and later than the screen save, and the power down computer is not set to never.  If the monitor goes into screen saver mode, but is reactivated before the power save mode activates, then the power save mode still activates at its scheduled time, even with activity in the screen.  Waving the mouse or keystrokes will reactivate the monitor.


Version-Release number of selected component (if applicable):
gpm-1.20.6-3.fc11.x86_64


How reproducible:  Under specified conditions, every time.


Steps to Reproduce:
1. Set screensaver on, idle time to 1 minute
2. Set power save on, idle time to 3 minutes
3. Set power down computer on, idle time to 12 minutes
4. Wait until monitor goes into saver mode, 1 minute.
5. Wave the mouse around.
6. Wait another two minutes.  Screen will go into power save mode.
7. Wave mouse, screen reactivates.
  
Actual results:  Spurious power save


Expected results: Power save is cancelled.


Additional info:
See bugzilla 501601 for some tests I did.
Nouveau driver, crt monitor, old video card, not eligible for modeset according to nouveau.
Comment 2 Adam Williamson 2009-08-10 13:59:40 EDT
Actually, the reporter initially commented on the bug for that issue - 501601 - but I commented that I don't believe it is the same issue, and asked him to open a separate report.

If you read the symptoms and the tests on 501601 carefully, the reporter is able to entirely mitigate this problem by changing the timeouts, which is not the case with 501601. This appears, to me, to be a different bug.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Richard Hughes 2009-08-20 08:31:11 EDT

*** This bug has been marked as a duplicate of bug 501601 ***

Note You need to log in before you can comment on or make changes to this bug.