This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 516369 - some dependent libraries missing for xauth in initrd.img for s390x
some dependent libraries missing for xauth in initrd.img for s390x
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
s390x Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ZedoraTracker
  Show dependency treegraph
 
Reported: 2009-08-08 19:17 EDT by Steffen Maier
Modified: 2009-08-24 22:35 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-24 22:35:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Ensure libraries are copied to initrd.img for xauth (1.15 KB, patch)
2009-08-23 12:15 EDT, Steffen Maier
no flags Details | Diff

  None (edit)
Description Steffen Maier 2009-08-08 19:17:03 EDT
Description of problem:
On logging in over the network using ssh with X11 forwarding, ld.so reports an error on missing shared library for executing xauth:
/sbin/xauth: error while loading shared libraries: libXau.so.6: cannot open shar
ed object file: No such file or directory

Version-Release number of selected component (if applicable):
anaconda-11.5.0.59-1.fc11.kh.1.s390x

How reproducible:
Boot/IPL Fedora on s390x install system from kernel.img, generic.prm, and initrd.img, configure network (linuxrc.s390) and then login over the network using ssh with X11 forwarding.

Actual results:
Xauth cannot be executed and hence no MIT magic cookies for X11 authentication can be configured by sshd.

Expected results:
Even though I would not recommend using X11 for GUI install, since it requires recent X extensions many X servers might not have, but rather VNC instead, xauth should still be executable without error.

Additional info:
I had to copy the following shared libraries into initrd.img to make it work:
-bash-4.0# cp -va /usr/lib64/libXau.so.6* initrd/lib64/
`/usr/lib64/libXau.so.6' -> `initrd/lib64/libXau.so.6'
`/usr/lib64/libXau.so.6.0.0' -> `initrd/lib64/libXau.so.6.0.0'
-bash-4.0# cp -va /usr/lib64/libXext.so.6* initrd/lib64/
`/usr/lib64/libXext.so.6' -> `initrd/lib64/libXext.so.6'
`/usr/lib64/libXext.so.6.4.0' -> `initrd/lib64/libXext.so.6.4.0'
-bash-4.0# cp -va /usr/lib64/libXmuu.so.1* initrd/lib64/
`/usr/lib64/libXmuu.so.1' -> `initrd/lib64/libXmuu.so.1'
`/usr/lib64/libXmuu.so.1.0.0' -> `initrd/lib64/libXmuu.so.1.0.0'
-bash-4.0# cp -va /usr/lib64/libX11.so.6* initrd/lib64/
`/usr/lib64/libX11.so.6' -> `initrd/lib64/libX11.so.6'
`/usr/lib64/libX11.so.6.2.0' -> `initrd/lib64/libX11.so.6.2.0'
-bash-4.0# cp -vau /usr/lib64/libxcb.so.1* initrd/lib64/
`/usr/lib64/libxcb.so.1' -> `initrd/lib64/libxcb.so.1'
`/usr/lib64/libxcb.so.1.1.0' -> `initrd/lib64/libxcb.so.1.1.0'

Sorry, I don't have access to a working build system (pungi) so I cannot modify and test the build scripts to account for the necessary changes.

This is what xauth is linked against:
-bash-4.0# ldd `which xauth`
        linux-vdso64.so.1 =>  (0x0000020000024000)
        libXau.so.6 => /usr/lib64/libXau.so.6 (0x0000020000032000)
        libXext.so.6 => /usr/lib64/libXext.so.6 (0x0000020000036000)
        libXmuu.so.1 => /usr/lib64/libXmuu.so.1 (0x0000020000049000)
        libX11.so.6 => /usr/lib64/libX11.so.6 (0x000002000004d000)
        libc.so.6 => /lib64/libc.so.6 (0x0000020000198000)
        libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x0000020000332000)
        libdl.so.2 => /lib64/libdl.so.2 (0x0000020000350000)
        /lib/ld64.so.1 (0x0000020000000000)
Comment 1 Steffen Maier 2009-08-23 12:15:58 EDT
Created attachment 358364 [details]
Ensure libraries are copied to initrd.img for xauth

As discussed here: https://www.redhat.com/archives/anaconda-devel-list/2009-August/msg00183.html
Comment 2 David Cantrell 2009-08-24 22:35:45 EDT
Applied to git repo.

Note You need to log in before you can comment on or make changes to this bug.