Bug 51638 - nspluginscan dies on SIGSEV11
nspluginscan dies on SIGSEV11
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: kdebase (Show other bugs)
roswell
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-13 10:21 EDT by lethalwp
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-13 10:22:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of nspluginscan (79.58 KB, text/plain)
2001-08-13 10:22 EDT, lethalwp
no flags Details

  None (edit)
Description lethalwp 2001-08-13 10:21:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010808

Description of problem:


How reproducible:
Always

Steps to Reproduce:
1.just start it up
2.
3.
	

Additional info:

haven't found the direct causes

[lethalwp@little avifile]$ rpm -qf `which nspluginscan` 
kdebase-2.2-0.cvs20010725.1


[lethalwp@little avifile]$ nspluginscan 
KCrash: crashing.... crashRecursionCounter = 2
KCrash: Application Name = nspluginscan path = <unknown> pid = 19484


(no debugging symbols found)...(no debugging symbols found)...
0x40da5ee9 in __wait4 () from /lib/i686/libc.so.6
#0  0x40da5ee9 in __wait4 () from /lib/i686/libc.so.6
#1  0x40e207c4 in __DTOR_END__ () from /lib/i686/libc.so.6
#2  0x40506cf8 in KCrash::defaultCrashHandler () at eval.c:41
#3  <signal handler called>
#4  0x4000dabf in _dl_init () at eval.c:41
#5  0x40e03b73 in dl_open_worker (a=0xbfffe6b0) at dl-open.c:313
#6  0x4000d663 in _dl_catch_error () at eval.c:41

#7  0x40e03d9e in _dl_open (file=0x8097108 "/usr/lib/mozilla/plugins/rpnp.so", 

    mode=-2147483647, caller=0x40584d25) at dl-open.c:359
#8  0x405b8385 in dlopen_doit (a=0xbfffe820) at dlopen.c:39
#9  0x4000d663 in _dl_catch_error () at eval.c:41
#10 0x405b870b in _dlerror_run (operate=0x405b8350 <dlopen_doit>, 
    args=0xbfffe820) at dlerror.c:130
#11 0x405b8336 in __dlopen_check (
    file=0x8097108 "/usr/lib/mozilla/plugins/rpnp.so", mode=1) at dlopen.c:53
#12 0x40584d25 in sys_dl_open () at eval.c:41
#13 0x40582570 in tryall_dlopen () at eval.c:41
#14 0x40583930 in lt_dlopen () at eval.c:41
#15 0x4051b15d in KLibLoader::library () at eval.c:41
#16 0x0804b3b4 in KConfigBase::writeEntry () at eval.c:41
#17 0x08050300 in KConfigBase::writeEntry () at eval.c:41
#18 0x40d086b7 in __libc_start_main (

    main=0x804fa60 <KConfigBase::writeEntry(char const *, QStringList const
&, char, bool, bool, bool)+24580>, argc=1, ubp_av=0xbffff9a4, 

    init=0x8049594 <_init>, fini=0x80515a0 <_fini>, 
    rtld_fini=0x4000db64 <_dl_fini>, stack_end=0xbffff99c)
    at ../sysdeps/generic/libc-start.c:129
Comment 1 lethalwp 2001-08-13 10:22:15 EDT
Created attachment 27516 [details]
strace of nspluginscan
Comment 2 Bernhard Rosenkraenzer 2001-08-13 10:24:05 EDT
Can't reproduce this with kdelibs 2.2-5, kdebase 2.2-3

Note You need to log in before you can comment on or make changes to this bug.