Bug 5164 - Can't start X.
Can't start X.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
6.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-09-16 15:27 EDT by kalatwal
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-05 14:27:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kalatwal 1999-09-16 15:27:31 EDT
RedHat 6.0  Kernel 2.2.5-15 on i586
Hitachi Pentium I 133MMX Laptop

Started out as not being able to logout of gnome using
menu item on GUI.  I used xterm window and "shutdown -h
now' instead.  Progressed to not being able to use
any menu item, and then not being able to start X.  Has
occurred at three times.  Only solution re-format and
completely re-intall linux.  Makes RedHat totally useless
for me.


Error Output:
_FontTransSocketUNIXConnect: Can't connect: errno = 111
failed to se default font path 'unix/: -1'
Fatal server error:
could not default font 'fixed'
When reporting a problem related to a server crash, please
send the full server output, not just the last messages
_X11TransSocketUNIXConnect: Can't connect: errno = 111
giving up.
Xinit: Connection refused (errno 111): unable to connect to
Xserver
Xinit: No such process (errno 3): Server error.

------- Additional Comments From   09/17/99 18:58 -------
The exact same thing happened to me, except I am using a AMD K6-2
300MHz.  Since it gave the error about fonts, I checked up and found
that xfs was NOT running.  Logging in as root and executing "xfs"
would then allow me to start X, but I could only use X as root--trying
to start X from any other user resulted in the gnome blue background
loading but nothing else.  Since then I have reinstalled Redhat and
used only KDE and have had no problems (I think it is something in
GNOME).

Note You need to log in before you can comment on or make changes to this bug.