Bug 51642 - imap-2000c update won't install because of openssl conflicts
imap-2000c update won't install because of openssl conflicts
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: imap (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-13 10:31 EDT by schmoe
Modified: 2007-04-18 12:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-19 11:04:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description schmoe 2001-08-13 10:31:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.16-22 i586)

Description of problem:
A security advisory (RHSA-2001:094-03) was released suggesting update to
imap-2000c.  Upgrade to that package fails because it requires
libcrypto.so.1 and libssl.so.1.  Upgrade of the openssl RPMs from
-0.9.5a-14 to 0.9.6-9 failes because many other packages require
libcrypto.so.0.  

How reproducible:
Always

Steps to Reproduce:
1.rpm -Uvh imap-2000c-10.i386.rpm imap-devel-200c-10.i386.rpm
2.rpm -Uvh openssl-*-0.9.6-9.i383.rpm
3.
	

Actual Results:  error: failed dependencies:
	libcrypto.so.0 is needed by curl-7.4.1-1
	libcrypto.so.0 is needed by cyrus-sasl-1.5.24-11
	libcrypto.so.0 is needed by fetchmail-5.5.0-3
	libcrypto.so.0 is needed by python-1.5.2-27
	libcrypto.so.0 is needed by perl-SSLeay-1.05-0.1RS
	libcrypto.so.0 is needed by stunnel-3.10-2
	libcrypto.so.0 is needed by mutt-1.2.5i-8.7
	libcrypto.so.0   is needed by pine-4.33-7
	libcrypto.so.0   is needed by openssh-2.5.2p2-1.7.2
	libcrypto.so.0   is needed by openssh-clients-2.5.2p2-1.7.2
	libcrypto.so.0   is needed by openssh-server-2.5.2p2-1.7.2
	libcrypto.so.0   is needed by mod_ssl-2.8.1-7
	libssl.so.0 is needed by curl-7.4.1-1
	libssl.so.0 is needed by fetchmail-5.5.0-3
	libssl.so.0 is needed by python-1.5.2-27
	libssl.so.0 is needed by perl-SSLeay-1.05-0.1RS
	libssl.so.0 is needed by stunnel-3.10-2
	libssl.so.0 is needed by mutt-1.2.5i-8.7
	libssl.so.0   is needed by pine-4.33-7
	libssl.so.0   is needed by mod_ssl-2.8.1-7


Expected Results:  imap and openssl packages should be updated.

Additional info:
Comment 1 Mike A. Harris 2001-08-15 09:13:21 EDT
I believe you need to -ivh the openssl packages.  IIRC 0.9.5 and
0.9.6 are both required.  THis might mean that imap should have
more specific deps tho.

Nalin, care to comment?
Comment 2 schmoe 2001-08-15 09:29:42 EDT
An rpm -ivh on the openssl packages fails, due to conflicts with
openssl-0.9.5a-14.  I also don't
understand how I could manage having both packages installed since they have the
same name
(what would rpm -q or rpm -e or a future rpm -Uvh do?).

In any case, this is not a fix that allows me to install the new version of
imap.
Comment 3 Mike A. Harris 2001-09-18 07:42:20 EDT
Nalin?  Can you comment at all on the openssl issue?  I don't see a
problem in my testing, but maybe I'm missing something.
Comment 4 Jerry Clotfelter 2001-09-19 11:04:53 EDT
I also cannot find any rpms that satisfy the dependency requirements
for imap-2000c

# rpm -U imap-2000c-10.i386.rpm 
error: failed dependencies:
	libcrypto.so.1   is needed by imap-2000c-10
	libssl.so.1   is needed by imap-2000c-10

The two new openssl libraries on updates only have the following libs:

# rpm -qlp openssl-0.9.6-9.i386.rpm  | grep lib
/usr/lib/libcrypto.so.0.9.6
/usr/lib/libssl.so.0.9.6
/usr/share/ssl/lib
# rpm -qlp openssl095a-0.9.5a-9.i386.rpm  | grep lib
/usr/lib/libcrypto.so.0.9.5a
/usr/lib/libssl.so.0.9.5a

From which package did your libs originate?
Comment 5 Mike A. Harris 2001-10-04 15:30:56 EDT
Well, I don't know how this one got past me for so long....

rpm -qp --provides openssl-0.9.6-9.i386.rpm
libcrypto.so.1
libssl.so.1
openssl = 0.9.6-9

The above openssl package is what you need, and it is an update.  There
is no bug here.  Use up2date if you have difficulty resolving dependancies.

Hint:  RPM can take multiple packages as arguments, including wildcards.
Comment 6 Mike A. Harris 2001-10-04 15:44:51 EDT
I happened to have a clean 7.0 system...

[root@dhcpd248 i386]# rpm -Uvh imap-2000c-10.i386.rpm openssl-0.9.6-9.i386.rpm
openssl095a-0.9.5a-9.i386.rpm
imap                        ##################################################
openssl                     ##################################################
openssl095a                 ##################################################

Note You need to log in before you can comment on or make changes to this bug.