Bug 51643 - broken gnome menus in russian KDE
Summary: broken gnome menus in russian KDE
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-13 14:51 UTC by Leonid Kanter
Modified: 2007-04-18 16:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-25 19:38:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (295.52 KB, image/png)
2001-08-13 14:54 UTC, Leonid Kanter
no flags Details
non-translated items, newly created user (110.58 KB, image/png)
2001-08-28 15:39 UTC, Leonid Kanter
no flags Details
migrated user, translated messages (120.63 KB, image/png)
2001-08-28 15:45 UTC, Leonid Kanter
no flags Details

Description Leonid Kanter 2001-08-13 14:51:40 UTC
Description of Problem:

kde panel is unable to show gnome menu items, when kde charset, listed in 
/usr/share/locale/ru/charset, is utf8, while russian entries in
/usr/share/gnome/apps/*/*.desktop are plain 8-bit koi8-r.

How Reproducible:

always

Steps to Reproduce:
1. start kde, select russian language and koi8-r encoding, restart kde

Actual Results:

"?" in place of cyrillic characters in gnome menus

Expected Results:

cyrillic characters must be present

Additional Information:
	
This problem was present in kde-2.0. In kde-2.1 (redhat-7.1) it disappeared
and now it's back again. This problem is a mirror of gnome-libs problem,
already fixed by redhat (gnome-libs-1.2.13-utf8menu.patch).

Comment 1 Leonid Kanter 2001-08-13 14:54:40 UTC
Created attachment 27517 [details]
screenshot

Comment 2 Bernhard Rosenkraenzer 2001-08-13 15:20:38 UTC
Odd that this presumably worked in 2.1 - I've just run a diff on the code in 
question and it's the exact same thing.

Do you have the exact version of kdelibs and kdebase for the version that 
worked?


Comment 3 Leonid Kanter 2001-08-13 15:32:52 UTC
I know exactly that with kdebase-2.1.1-8 and kdelibs-2.1.1-5 everything is OK.

Comment 4 Glen Foster 2001-08-13 19:07:41 UTC
We (Red Hat) should really try to fix this before next release.

Comment 5 Leonid Kanter 2001-08-21 22:40:55 UTC
With kdebase-2.2-4 behavior has changed. Looks like it simply use non-translated
english strings from gnome .desktop files, that actually is much better than "??".

Comment 6 Bernhard Rosenkraenzer 2001-08-27 12:12:56 UTC
Does this still happen in the current version (after the Charset fixes)?


Comment 7 Leonid Kanter 2001-08-27 12:41:33 UTC
Latest rawhide kdebase is still 2.2-6. I've just verified that for newly created
user folder names are translated and item names are not translated, for both
native KDE and GNOME menu items.


Comment 8 Leonid Kanter 2001-08-28 15:37:29 UTC
Strange things happen. I have two user accounts on the same box, one migrated
from RH 7.1 and one newly created. For migrated account everything is OK with
menu and for newly created account - not. I copied ~/Desktop and ~/.kde content
to new account - nothing changed. Screenshots will follow. Hope this information
may help. kdebase-2.2-8

Comment 9 Leonid Kanter 2001-08-28 15:39:53 UTC
Created attachment 29914 [details]
non-translated items, newly created user

Comment 10 Leonid Kanter 2001-08-28 15:45:21 UTC
Created attachment 29915 [details]
migrated user, translated messages

Comment 11 Leonid Kanter 2002-09-25 20:59:32 UTC
This bug was not reproduced in 7.3 release.


Note You need to log in before you can comment on or make changes to this bug.