This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 516445 - Show Dashboard Shortcut (ctrl-f12) doesn't work after upgrade to kde 4.3.0
Show Dashboard Shortcut (ctrl-f12) doesn't work after upgrade to kde 4.3.0
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
11
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-09 15:13 EDT by Fabio Canepa
Modified: 2009-09-12 21:01 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-12 21:01:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 203482 None None None Never

  None (edit)
Description Fabio Canepa 2009-08-09 15:13:17 EDT
Description of problem:
I've update my fedora to kde-4.3.0 using the following command:
sudo yum --enablerepo=updates-testing groupupdate 'KDE (K Desktop Environment)'

Version-Release number of selected component (if applicable):
kdebase-workspace-4.3.0-5.fc11.x86_64


How reproducible:

Steps to Reproduce:
1. Open some applications
2. Press ctrl-f12
  
Actual results:
Dashboard is not showed

Expected results:
Dashboard is showed as with kde 4.2

Additional info:
Going to system-settings -> Keyboard & Mouse -> Global Keyboard Shortcut I found that Show Dashboard 'Plasma Workspace' was set to custom but without any key combination. Setting to default make shortcut works again. Before updagre to kde 4.3 ctrl-f12 was bind to "Show Dashboard"
Comment 1 Jaroslav Reznik 2009-08-10 07:56:18 EDT
Confirmed.
Comment 2 Jaroslav Reznik 2009-08-10 08:49:49 EDT
Newly created users are not affected so it looks like 4.2 -> 4.2 migration issue.
Comment 3 Ben Boeckel 2009-08-10 09:12:06 EDT
Hmm, my two machines I updated both have the dashboard working. Both were updated to 4.3.0, one from 4.2.4 (updates-testing) and another from 4.2.98 (kde-redhat).
Comment 4 Fabio Canepa 2009-08-10 09:17:47 EDT
My machine is a fedora 11 update from stable 4.2.4 to 4.3.0 using:
sudo yum --enablerepo=updates-testing groupupdate 'KDE (K Desktop Environment)'

After update ctrl-f12 was not working.
Comment 5 Lukáš Tinkl 2009-08-10 11:49:16 EDT
Not working either; strange thing is that when going into System Settings, and trying the "Default" shortcuts for the Plasma Workspace module, it warns me about duplicate global shortcuts (the other duplicate being the very same shortcut,  "Show Dashboard" :)
Comment 6 Steven M. Parrish 2009-08-11 10:19:14 EDT
Thank you for taking the time to report this issue.

This is an issue that needs to be addressed by the upstream developers. Please report this at http://bugs.kde.org and then add the upstream report information to this report.  We will monitor the upstream report for a resolution to this issue, and will review any bug fixes that become available for consideration in future updates.

Setting status to NEEDINFO, and awaiting upstream bug report URL for tracking.

Thanks in advance.

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Fabio Canepa 2009-08-11 17:18:34 EDT
Reported upstream:
https://bugs.kde.org/show_bug.cgi?id=203482
Comment 8 Kevin Kofler 2009-08-18 10:54:49 EDT
kglobalshortcutsrc changed incompatibly and needs a kconf_update script (the file has been touched by other kconf_update scripts in the past, so kconf_update should work on that file):

* in 4.2, the setting looked like:
[plasma]
Show Dashboard=Ctrl+F12,Ctrl+F12,Dashboard anzeigen

* in 4.3, the group needs to be changed to plasma-desktop (an unfortunate side effect of the rename):
[plasma-desktop]
Show Dashboard=Ctrl+F12,Ctrl+F12,Dashboard anzeigen

(FWIW, the localized string should probably not be in the config file, but that is unrelated to the bug at hand.)
Comment 9 Jaroslav Reznik 2009-08-24 09:41:55 EDT
Kconf_update script is already installed in /usr/share/kde4/apps/kconf_update (part of kdebase-workspace) but for unknow reason it does not work for all users. Maybe some race condition (i.e. the file being fixed while being used, then being rewritten with the old contents on app close).

As we are unable to find the real reason of this issue, users affected by this bug should update kglobalshortcutsrc manually, changing "plasma" to "plasma-desktop". Or they can use System settings shortcuts module.

This should be stated (or this bug link) in update description.
Comment 10 Kevin Kofler 2009-08-25 02:51:18 EDT
Taking this off the kde-4.3.0 tracker as we decided not to block the KDE 4.3.0 update on this. There were 2 reasons we did this:
* we are unable to find the cause of the bug, as a kconf_update supposed to handle the transition is already there and works for some people,
* there is a simple workaround.
See also Jaroslav Řezník's comment above.
Comment 11 Steven M. Parrish 2009-09-12 21:01:28 EDT
Thanks for reporting this upstream.  Going to close this report in favor of the upstream one.

Thanks again

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.