Bug 516446 - Sound will crackle and then stop playing
Sound will crackle and then stop playing
Status: CLOSED DUPLICATE of bug 506075
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-09 15:20 EDT by Jon Dufresne
Modified: 2009-08-13 10:51 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-13 10:51:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from pulseaudio when bug occurs (136.14 KB, text/plain)
2009-08-09 15:32 EDT, Jon Dufresne
no flags Details

  None (edit)
Description Jon Dufresne 2009-08-09 15:20:38 EDT
This problem first appeared in Fedora 11 and never appeared in Fedora 10.

When playing audio through totem, after some time the audio will crackle and then stop playing. To get sound to work again I need to kill totem wait a bit and then try again. This also occurs with mplayer but MUCH MUCH less frequently. This usually happens everytime I play an audio file.

I will attach the output from "pulseaudio -vvvvv". In the output I noticed many lines like:

---
D: protocol-native.c: Requesting rewind due to rewrite.
D: alsa-sink.c: Wakeup from ALSA!
D: alsa-sink.c: Requested to rewind 65536 bytes.
D: alsa-sink.c: Mhmm, actually there is nothing to rewind.
---

And 

---
W: ratelimit.c: 361 events suppressed
W: asyncq.c: q overrun, queuing locally
---
Comment 1 Jon Dufresne 2009-08-09 15:32:43 EDT
Created attachment 356820 [details]
output from pulseaudio when bug occurs
Comment 2 Lonni J Friedman 2009-08-12 16:18:32 EDT
Same problem here with Fedora11-i686.  I can pick any random mp3 and it will
play ok for a few seconds, and then everything goes to noise & static, and
after a few seconds, it just dies.  In /var/log/messages, I see the following:

Aug 12 13:12:31 netllama pulseaudio[6445]: alsa-source.c: Increasing minimal
latency to 1.00 ms
Aug 12 13:13:00 netllama pulseaudio[6445]: alsa-sink.c: Increasing minimal
latency to 1.00 ms
Aug 12 13:13:12 netllama pulseaudio[6445]: alsa-sink.c: Increasing minimal
latency to 2.00 ms
Aug 12 13:13:18 netllama pulseaudio[6445]: alsa-sink.c: Increasing minimal
latency to 4.00 ms
Aug 12 13:13:25 netllama pulseaudio[6445]: alsa-sink.c: Increasing minimal
latency to 8.00 ms
Aug 12 13:13:26 netllama pulseaudio[6445]: alsa-sink.c: Increasing minimal
latency to 16.00 ms
Aug 12 13:13:38 netllama pulseaudio[6445]: alsa-sink.c: Increasing minimal
latency to 26.00 ms

Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-sink.c: Increasing wakeup
watermark to 16.00 ms
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-sink.c: Increasing minimal
latency to 36.00 ms
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c: snd_pcm_avail()
returned a value that is exceptionally large: 4294962144 bytes (22369594 ms).
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c: Most likely this is a
bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA
developers.
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c: snd_pcm_dump():
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c: Hardware PCM card 0
'NVidia CK804' device 0 subdevice 0
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c: Its setup is:
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   stream       :
PLAYBACK
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   access       :
MMAP_INTERLEAVED
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   format       : S16_LE
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   subformat    : STD
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   channels     : 2
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   rate         : 48000
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   exact rate   : 48000
(48000/1)
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   msbits       : 16
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   buffer_size  : 16384
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   period_size  : 16384
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   period_time  : 341333
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   tstamp_mode  : ENABLE
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   period_step  : 1
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   avail_min    : 16384
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   period_event : 0
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   start_threshold  : -1
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   stop_threshold   :
1073741824
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   silence_threshold: 0
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   silence_size : 0
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   boundary     :
1073741824
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   appl_ptr     :
3818760
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   hw_ptr       :
3801088
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c: snd_pcm_delay()
returned a value that is exceptionally large: 342784 bytes (1785 ms).
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c: Most likely this is a
bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA
developers.
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c: snd_pcm_dump():
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c: Hardware PCM card 0
'NVidia CK804' device 0 subdevice 0
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c: Its setup is:
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   stream       :
PLAYBACK
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   access       :
MMAP_INTERLEAVED
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   format       : S16_LE
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   subformat    : STD
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   channels     : 2
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   rate         : 48000
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   exact rate   : 48000
(48000/1)
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   msbits       : 16
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   buffer_size  : 16384
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   period_size  : 16384
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   period_time  : 341333
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   tstamp_mode  : ENABLE
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   period_step  : 1
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   avail_min    : 16384
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   period_event : 0
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   start_threshold  : -1
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   stop_threshold   :
1073741824
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   silence_threshold: 0
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   silence_size : 0
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   boundary     :
1073741824
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   appl_ptr     :
3887880
Aug 12 13:13:50 netllama pulseaudio[6445]: alsa-util.c:   hw_ptr       :
3802184
Aug 12 13:13:55 netllama pulseaudio[6445]: ratelimit.c: 28455 events suppressed
Aug 12 13:14:00 netllama pulseaudio[6445]: ratelimit.c: 32650 events suppressed
Aug 12 13:14:00 netllama pulseaudio[6445]: asyncq.c: q overrun, queuing locally
Aug 12 13:14:00 netllama pulseaudio[6445]: asyncq.c: q overrun, queuing locally
Aug 12 13:14:00 netllama pulseaudio[6445]: asyncq.c: q overrun, queuing locally
Aug 12 13:14:00 netllama pulseaudio[6445]: asyncq.c: q overrun, queuing locally
Aug 12 13:14:00 netllama pulseaudio[6445]: asyncq.c: q overrun, queuing locally
Aug 12 13:14:00 netllama pulseaudio[6445]: asyncq.c: q overrun, queuing locally
Aug 12 13:14:00 netllama pulseaudio[6445]: asyncq.c: q overrun, queuing locally
Aug 12 13:14:00 netllama pulseaudio[6445]: asyncq.c: q overrun, queuing locally
Aug 12 13:14:00 netllama pulseaudio[6445]: asyncq.c: q overrun, queuing locally
Aug 12 13:14:00 netllama pulseaudio[6445]: asyncq.c: q overrun, queuing locally
Aug 12 13:14:00 netllama pulseaudio[6445]: asyncq.c: q overrun, queuing locally
Aug 12 13:14:04 netllama pulseaudio[6445]: cpulimit.c: Received request to
terminate due to CPU overload.
Aug 12 13:14:04 netllama pulseaudio[6445]: memblock.c: Memory pool destroyed
but not all memory blocks freed! 104485 remain.
Comment 3 Jon Dufresne 2009-08-12 20:40:10 EDT
I also see the problems from bug 506075 so this may be related or a duplicate.
Comment 4 Lennart Poettering 2009-08-13 10:51:39 EDT
These are follow up issues of bug 506075, caused by the broken snd_pcm_avail().

*** This bug has been marked as a duplicate of bug 506075 ***

Note You need to log in before you can comment on or make changes to this bug.