Bug 516469 - PTHREAD_PRIO_INHERIT does not mix well with POSIX condition variables
PTHREAD_PRIO_INHERIT does not mix well with POSIX condition variables
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Andreas Schwab
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 516995 F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-08-09 22:05 EDT by Lennart Poettering
Modified: 2009-08-17 12:10 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-17 12:10:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test case (1.38 KB, text/x-csrc)
2009-08-09 22:06 EDT, Lennart Poettering
no flags Details

  None (edit)
Description Lennart Poettering 2009-08-09 22:05:25 EDT
The attached test case blocks forever on kernel-2.6.31-0.139.rc5.git3.fc12.x86_64/glibc-2.10.90-12.x86_64. It works fine on Program works as intended on kernel-2.6.31-0.38.rc1.git7.fc12.i586/glibc-2.10.1-2.i686.

Disabling PTHREAD_PRIO_INHERIT for the mutex in question makes the test case work properly.

Not sure if this is a kernel or glibc problem.
Comment 1 Lennart Poettering 2009-08-09 22:06:22 EDT
Created attachment 356836 [details]
test case
Comment 2 Lennart Poettering 2009-08-10 10:25:09 EDT
peterz thinks it's a kernel problem. Reassigning.
Comment 3 Andreas Schwab 2009-08-10 10:55:26 EDT
No, it isn't.

<http://sourceware.org/ml/libc-alpha/2009-08/msg00024.html>
Comment 4 Darren Hart 2009-08-10 12:21:02 EDT
Took a look at the trace, the kernel is doing what it should.  If you put the thread to sleep with FUTEX_WAIT_REQUEUE_PI_PRIVATE (0x8b) you have to wake it up with FUTEX_CMP_REQUEUE_PI_PRIVATE (0x8c), but the trace shows a call to FUTEX_WAKE_PRIVATE instead.  This causes the kernel routine the thread is blocked in to wake, detect invalid usage, and return EINVAL.  This is a glibc bug.
Comment 5 Andreas Schwab 2009-08-17 12:10:42 EDT
Fixed in 2.10.90-14.

Note You need to log in before you can comment on or make changes to this bug.