Bug 51649 - Install exited abnormally
Install exited abnormally
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-08-13 11:43 EDT by Lyle Bickley
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-08-13 21:21:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Lyle Bickley 2001-08-13 11:43:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.4-4GB i586)

Description of problem:
Traceback shows:
File "/usr/bin/anaconda", line 3, in ?
import sys, os, signal
Import Error: No module named os
install exited abnormally

How reproducible:

Steps to Reproduce:
1.  Tried booting with CD blank (unpartitioned HD)
2.  Tried booting with floppy "boot.img" (unpartitioned HD)
3.  Tried booting with both above with paritioned HD (Linux and Swap using
Partition Magic)
4.  Booted and installed SuSE 7.2 on same system w/o error,  Booted and
installed OpenBSD 1.5 on same system w/o error.

Actual Results:  From boot sequence:

running /sbin/loader
Running anaconda - please wait
Could not find platform independent libraries <prefix>
Could not find platform dependent libraries <exec-prefix>
Consider setting $PYTHONHOME to <prefix>[:exec-prefix]
(traceback as described above)

Expected Results:  Normal Install

Additional info:

This is a "vanilla" unit-under-test inhouse system:

IDE - Primary Master - 8GB HDD
IDE - Secondary Master - 40X CDROM
256 MB RAM
AMD K6-2/500
Creative Soundcard
3DFX Voodoo3
Standard FDD
Comment 1 Brent Fox 2001-08-13 11:45:16 EDT
I think that you might have a bad cd.  Press <Ctrl><Alt><F4> and see if there
are any error messages related to cdroms.
Comment 2 Lyle Bickley 2001-08-13 21:21:52 EDT
Your suggestion was almost correct ;)  The problem turned out to be a CDROM
drive and/or Motherboard that couldn't handle DMA properly.  NetBSD and SuSE
both turn off DMA and test the device's capability to handle DMA.  If it works,
then DMA is enabled.  As I recollect, Winslop (er, Windows 98SE) does this too.

Redhat enables DMA and assumes it will be OK.  You might want to change your
strategy.  I "forced" DMA off in the BIOS and everything worked O.K.  (Although
it looks like RH enables DMA anyway, tries 5 reads and then turns DMA off
subsequently - observed from the boot log).
Comment 3 Brent Fox 2001-08-14 10:59:50 EDT
Oh.  If you boot with 'linux ide=nodma' at the cd boot screen, things would have
worked ok and you wouldn't have to have changed the bios.  I think we will
disable dma transfers for cdroms in the future.

The problem is that some drives can't do dma transfers, but they fall back to a
non dma mode.  Other drives don't fall back properly, and that's where the
problems come from.  Thanks for your report.
Comment 4 Lyle Bickley 2001-08-14 12:14:05 EDT
Using "linux ide=nodma" would have worked, but would have made the HDD not use
DMA (which it was capable of doing).  The BIOS technique allowed me to use DMA
on my primary IDE and no DMA on my secondary IDE to which the CDROM was

I totally agree with you that eliminating DMA on CDROM/DVD is a good thing.  It
seldom (if ever) brings any performance advantage to CDROM/DVD devices and often
brings headaches due to hardware DMA "incompatibilies".

Note You need to log in before you can comment on or make changes to this bug.