Bug 5165 - lilo fails to pass correct root dev
Summary: lilo fails to pass correct root dev
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: lilo (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Keywords:
: 4758 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-16 20:22 UTC by gerald
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-05 06:23:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description gerald 1999-09-16 20:22:46 UTC
I run RH 6.0 on an ASUS L7300 laptop.

The kernel will frequently (at random) panic at boot time
with the message

      VFS: Cannot open root device 00:30

Sometimes it will boot correctly for several times.

It is not a misconfiguration since the same harddrive
boots fine in a different (brand) laptop. Several people
have reported the same problem.

I have a correct root=/dev/hda5 entry in my lilo.conf and
I already tried rdev to hard code the option into the kernel.
The only remedy is to specify the option root=/dev/hda5 at
the lilo prompt.

Comment 1 Cristian Gafton 1999-10-05 06:22:59 UTC
*** Bug 4758 has been marked as a duplicate of this bug. ***

Arguments passed to the lilo boot prompt do not reach the
kernel.  Even the default ones setup by lilo (like BOOT=)
don't make it.  Try "cat /proc/cmdline".  This will
sometimes cause kernels to not boot, and I'd assume that it
would not boot kernels installed on a disk other than the
kernel default boot device.

Probably not the desired effect for a "Red Hat Certified
System". ;)

BTW: Grub works fine

------- Additional Comments From gafton@redhat.com  09/20/99 11:19 -------
Doug is working on a fix for this.

------- Additional Comments From gafton@redhat.com  09/20/99 11:19 -------


*** Bug 2720 has been marked as a duplicate of this bug. ***

On an Intel Sitka Platform (4-way Xeon, Symbios 896
on-board SCSI) after initial installation the install kernel
panic's (not able to find root filesystem).  I have talked
to Doug Ledford at Red Hat and he says this is a known
problem and was thought to be fixed in a beta version.  We
have recreated the problem on several Sitka's at Intel
using Red Hat 6.0 Gold.

------- Additional Comments From jxh@msi.com  05/10/99 17:19 -------
It seems that something goes wrong in parsing the lilo.conf file. If
I use the lilo.conf file installed by default everything works fine.
But if I replace the
prompt
timeout=50
sequence
with
delay=20
the kernel panics (not able to find root file system). This is on a
Dell Inspiron 3200.

------- Additional Comments From dledford@redhat.com  05/13/99 01:54 -------
A new lilo version is now under testing from Werner Almesberger.  We
will be working with him on this and should have an updated version
soon.  The test version currently available is lilo-22dev0 and is
available from the ftp site
ftp://lrcftp.epfl.ch/pub/people/almesber/lilo/lilo-22dev0.tar.gz

Comment 2 Cristian Gafton 1999-10-05 06:23:59 UTC
The lilo package available in RH 6.1 and on rawhide fixes this
problem.


Note You need to log in before you can comment on or make changes to this bug.