Bug 516549 - Does libgcrypt need to be blacklisted from prelink?
Does libgcrypt need to be blacklisted from prelink?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libgcrypt (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-10 08:07 EDT by Tim Waugh
Modified: 2009-08-10 09:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-10 08:31:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2009-08-10 08:07:31 EDT
In bug #506796 there is some discussion of prelink causing problems with libgcrypt.  Is this the case?  Should it be blacklisted?
Comment 1 Tomas Mraz 2009-08-10 08:31:37 EDT
The FIPS support in libgcrypt conflicts with prelinking. However the FIPS support is meant only for testing purposes in fedora - the module is not validated in the Fedora. So it does not make much sense to run it in the FIPS mode except for testing. It would not be a good idea to block prelinking just for testing purposes. Also if you'd like to run the whole system in the FIPS mode, you can disable prelink altogether on the distribution.

As for the other issue that seems to be fixed by un-prelinking - I don't think this is a real conflict of libgcrypt with prelink - it rather seems that libgcrypt or prelink is somehow broken on the reporter's computer only. I am not aware of any other reports where prelinking libgcrypt made its users crashing.
Comment 2 Tim Waugh 2009-08-10 09:09:15 EDT
Thank you.

Note You need to log in before you can comment on or make changes to this bug.