Bug 516587 - 802.1q vlan on guest with rtl8139 nic doesn't effect
802.1q vlan on guest with rtl8139 nic doesn't effect
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Tim Burke
Lawrence Lim
: FutureFeature
Depends On:
Blocks: Rhel5KvmTier3
  Show dependency treegraph
 
Reported: 2009-08-10 11:37 EDT by Amos Kong
Modified: 2015-05-24 20:05 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 10:56:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Amos Kong 2009-08-10 11:37:04 EDT
Description of problem:
When run vlan test in the guests, After configure by vconfig command, 802.1q vlan on guest with rtl8139 nic doesn't effect.
Vlan test the 802.1q vlan function of nic(rtl8139/e1000/virtio) on guest, testing steps:
    1) Create two VMs with rtl8139/e1000/virtio nic
    2) Setup guests in different vlan by vconfig and test communication by ping using hard-coded ip address
    3) Setup guests in same vlan and test communication by ping
    4) Recover the vlan config

Version-Release number of selected component (if applicable):
etherboot-zroms-kvm-5.4.4-10.el5
kmod-kvm-83-105.el5
kvm-83-105.el5
kvm-tools-83-105.el5
kvm-qemu-img.83-105.el5
kvm-debuginfo-83-105.el5

How reproducible:
100%

Steps to Reproduce:
1.Boot two VMs with rtl8139 nic on host

2.Setup guests in different vlan by vconfig and test communication by ping using hard-coded ip address
On guest1:
#vconfig add eth0 10
#ifconfig eth0.10 192.168.123.11
On guest2:
#vconfig add eth0 20
#ifconfig eth0.20 192.168.123.12
#ping 192.168.123.11

3.Setup guests in same vlan and test communication by ping
On guest1:
#vconfig add eth0 10
#ifconfig eth0.10 192.168.123.11
On guest2:
#vconfig add eth0 10
#ifconfig eth0.10 192.168.123.12
#ping 192.168.123.11

  
Actual results:
Guest is unexpectedly pingable in different vlan


Expected results:
1. guests in different vlan can't ping successfully
2. guests in same valn can ping successfully

Additional info:
1. qemu-kvm command line:
/home/amos/Project/multi/kvm-autotest/client/tests/kvm_runtest_2/qemu -name 'vm1' -monitor tcp:0:5400,server,nowait -drive file=/home/amos/Project/multi/kvm-autotest/client/tests/kvm_runtest_2/images/RHEL-Server-5.3-64.0.qcow2,if=ide,boot=on -net nic,vlan=0,macaddr=00:11:22:33:8D:01,model=rtl8139 -net tap,vlan=0,ifname=rtl8139,script=/etc/qemu-ifup-switch,downscript=no -m 512 -usbdevice tablet -rtc-td-hack -no-hpet -cpu qemu64,+sse2 -smp 1 -vnc :0
/home/amos/Project/multi/kvm-autotest/client/tests/kvm_runtest_2/qemu -name 'vm2' -monitor tcp:0:5401,server,nowait -drive file=/home/amos/Project/multi/kvm-autotest/client/tests/kvm_runtest_2/images/RHEL-Server-5.3-64.0.qcow2,if=ide,boot=on -net nic,vlan=0,macaddr=00:11:22:33:8D:02,model=rtl8139 -net tap,vlan=0,ifname=tap_rtl8139_2,script=/etc/qemu-ifup-switch,downscript=no -m 512 -usbdevice tablet -rtc-td-hack -no-hpet -cpu qemu64,+sse2 -smp 1 -vnc :1
2.cpuinfo: Intel(R) Core(TM)2 Quad CPU    Q9400  @ 2.66GHz
3.network status
[root@dhcp-66-70-53 staf-kvm]# brctl show
bridge name bridge id  STP enabled interfaces
switch  8000.0023ae8ff38d no  tap_rtl8139
                              tap_rtl8139_2
                              eth0
virbr0  8000.000000000000 yes
Comment 1 Dor Laor 2009-10-29 18:06:28 EDT
Does it works with e1000?
Comment 2 Amos Kong 2009-10-30 06:11:22 EDT
(In reply to comment #1)
> Does it works with e1000?  

vlan_tag works well using e1000.
Only rtl8139 exists this problem.
Comment 6 RHEL Product and Program Management 2011-01-11 15:46:51 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 7 RHEL Product and Program Management 2011-01-11 17:46:54 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.

Note You need to log in before you can comment on or make changes to this bug.