Bug 516692 - virt-manager throws python errors when trying to launch domain
virt-manager throws python errors when trying to launch domain
Status: CLOSED DUPLICATE of bug 473154
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
1
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-11 02:46 EDT by Tim McConnell
Modified: 2009-08-14 13:49 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-14 13:49:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim McConnell 2009-08-11 02:46:07 EDT
Description of problem:
virt-manager throws python errors when trying to launch domain

Version-Release number of selected component (if applicable):
0.7.0

How reproducible:
Click on virtual Machine and try to run 

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Receive this in "Error Details" Window: 
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 272, in show_details
    details = vmmDetails(self.get_config(), con.get_vm(uuid), self)
  File "/usr/share/virt-manager/virtManager/details.py", line 341, in __init__
    self.prepare_hw_list()
  File "/usr/share/virt-manager/virtManager/details.py", line 1605, in prepare_hw_list
    self.populate_hw_list()
  File "/usr/share/virt-manager/virtManager/details.py", line 1631, in populate_hw_list
    self.repopulate_hw_list()
  File "/usr/share/virt-manager/virtManager/details.py", line 1662, in repopulate_hw_list
    for diskinfo in self.vm.get_disk_devices():
  File "/usr/share/virt-manager/virtManager/domain.py", line 728, in get_disk_devices
    return self._parse_device_xml(_parse_disk_devs)
  File "/usr/share/virt-manager/virtManager/domain.py", line 979, in _parse_device_xml
    raise RuntimeError(_("Error parsing domain xml: %s") % str(e))
RuntimeError: Error parsing domain xml: cannot send data: Broken pipe


Expected results:
To be able to launch the virtual machine

Additional info:
Upon request
Comment 1 Mark McLoughlin 2009-08-11 14:29:14 EDT
Is this rawhide? You have the version set to 1?

What version of libvirt, virt-manager etc. is this?

See here for the kind of information that would be useful:

  https://fedoraproject.org/wiki/Reporting virtualization bugs

Thanks
Comment 2 Tim McConnell 2009-08-11 20:02:30 EDT
(In reply to comment #1)
> Is this rawhide?
No, the output from uname -r is:
2.6.29.6-217.2.3.fc11.i586
>You have the version set to 1?
qemu-0.10.5-3.fc11.i586
python-virtinst-0.400.3-8.fc11.noarch
virt-viewer-0.0.3-6.fc11.i586
virt-manager-0.7.0-5.fc11.i586
 
> What version of libvirt, virt-manager etc. is this?
libvirt-0.6.2-13.fc11.i586
See above for rest of versions 
> See here for the kind of information that would be useful:
> 
>   https://fedoraproject.org/wiki/Reporting virtualization bugs
> 
> Thanks  
From the page above I ran these commands: 

virsh capabilities
<capabilities>

  <host>
    <cpu>
      <arch>i686</arch>
    </cpu>
    <secmodel>
      <model>selinux</model>
      <doi>0</doi>
    </secmodel>
  </host>

  <guest>
    <os_type>hvm</os_type>
    <arch name='i686'>
      <wordsize>32</wordsize>
      <emulator>/usr/bin/qemu</emulator>
      <machine>pc</machine>
      <machine>isapc</machine>
      <domain type='qemu'>
      </domain>
      <domain type='kvm'>
        <emulator>/usr/bin/qemu-kvm</emulator>
      </domain>
    </arch>
    <features>
      <pae/>
      <nonpae/>
      <acpi default='on' toggle='yes'/>
      <apic default='on' toggle='no'/>
    </features>
  </guest>

  <guest>
    <os_type>hvm</os_type>
    <arch name='x86_64'>
      <wordsize>64</wordsize>
      <emulator>/usr/bin/qemu-system-x86_64</emulator>
      <machine>pc</machine>
      <machine>isapc</machine>
      <domain type='qemu'>
      </domain>
    </arch>
    <features>
      <acpi default='on' toggle='yes'/>
      <apic default='on' toggle='no'/>
    </features>
  </guest>

  <guest>
    <os_type>hvm</os_type>
    <arch name='mips'>
      <wordsize>32</wordsize>
      <emulator>/usr/bin/qemu-system-mips</emulator>
      <machine>mips</machine>
      <domain type='qemu'>
      </domain>
    </arch>
  </guest>

  <guest>
    <os_type>hvm</os_type>
    <arch name='mipsel'>
      <wordsize>32</wordsize>
      <emulator>/usr/bin/qemu-system-mipsel</emulator>
      <machine>mips</machine>
      <domain type='qemu'>
      </domain>
    </arch>
  </guest>

  <guest>
    <os_type>hvm</os_type>
    <arch name='sparc'>
      <wordsize>32</wordsize>
      <emulator>/usr/bin/qemu-system-sparc</emulator>
      <machine>sun4m</machine>
      <domain type='qemu'>
      </domain>
    </arch>
  </guest>

  <guest>
    <os_type>hvm</os_type>
    <arch name='ppc'>
      <wordsize>32</wordsize>
      <emulator>/usr/bin/qemu-system-ppc</emulator>
      <machine>g3beige</machine>
      <machine>mac99</machine>
      <machine>prep</machine>
      <domain type='qemu'>
      </domain>
    </arch>
  </guest>

  <guest>
    <os_type>xen</os_type>
    <arch name='i686'>
      <wordsize>32</wordsize>
      <emulator>/usr/bin/xenner</emulator>
      <machine>xenner</machine>
      <domain type='kvm'>
      </domain>
    </arch>
    <features>
      <pae/>
      <nonpae/>
      <acpi default='on' toggle='yes'/>
      <apic default='on' toggle='no'/>
    </features>
  </guest>

</capabilities>

cat /proc/cpuinfo
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 14
model name	: Genuine Intel(R) CPU           T2400  @ 1.83GHz
stepping	: 8
cpu MHz		: 1000.000
cache size	: 2048 KB
physical id	: 0
siblings	: 2
core id		: 0
cpu cores	: 2
apicid		: 0
initial apicid	: 0
fdiv_bug	: no
hlt_bug		: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 10
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx constant_tsc arch_perfmon bts pni monitor vmx est tm2 xtpr pdcm
bogomips	: 3657.27
clflush size	: 64
power management:

processor	: 1
vendor_id	: GenuineIntel
cpu family	: 6
model		: 14
model name	: Genuine Intel(R) CPU           T2400  @ 1.83GHz
stepping	: 8
cpu MHz		: 1000.000
cache size	: 2048 KB
physical id	: 0
siblings	: 2
core id		: 1
cpu cores	: 2
apicid		: 1
initial apicid	: 1
fdiv_bug	: no
hlt_bug		: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 10
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx constant_tsc arch_perfmon bts pni monitor vmx est tm2 xtpr pdcm
bogomips	: 3657.36
clflush size	: 64
power management:

in /var/log/libvirt/qemu/XP.log-20090811 I found this
LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin /usr/bin/qemu-kvm -S -M pc -m 512 -smp 1 -name XP -uuid 33bb2d14-af98-69a8-0f28-16cbe9785212 -monitor pty -pidfile /var/run/libvirt/qemu//XP.pid -localtime -no-acpi -boot c -drive file=/var/lib/libvirt/images/XP.img,if=ide,index=0,boot=on -drive file=/dev/sr0,if=ide,media=cdrom,index=2 -net nic,macaddr=54:52:00:3f:0a:84,vlan=0 -net tap,fd=17,vlan=0 -serial pty -parallel none -usb -usbdevice tablet -vnc 127.0.0.1:0 
qemu: could not open disk image /dev/sr0

If more is needed let me know
Comment 3 Tim McConnell 2009-08-13 01:31:25 EDT
Steps to reproduce correction: 

1. Install WindowsXP SP 3 from CD as a virtual machine thriugh virtual manger interface. 
2. Allow to be fully updated 
3. Shut down virtual machine 
4. Power down host machine (laptop) 
5. power on host 
6. run virt manager and try to start virtual machine 
7. receive  error

If it matters, Laptop is HP 530 with dual core processor 
cat /proc/cpuinfo
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 14
model name	: Genuine Intel(R) CPU           T2400  @ 1.83GHz
stepping	: 8
cpu MHz		: 1000.000
cache size	: 2048 KB
physical id	: 0
siblings	: 2
core id		: 0
cpu cores	: 2
apicid		: 0
initial apicid	: 0
fdiv_bug	: no
hlt_bug		: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 10
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx constant_tsc arch_perfmon bts pni monitor vmx est tm2 xtpr pdcm
bogomips	: 3657.48
clflush size	: 64
power management:

processor	: 1
vendor_id	: GenuineIntel
cpu family	: 6
model		: 14
model name	: Genuine Intel(R) CPU           T2400  @ 1.83GHz
stepping	: 8
cpu MHz		: 1000.000
cache size	: 2048 KB
physical id	: 0
siblings	: 2
core id		: 1
cpu cores	: 2
apicid		: 1
initial apicid	: 1
fdiv_bug	: no
hlt_bug		: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 10
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx constant_tsc arch_perfmon bts pni monitor vmx est tm2 xtpr pdcm
bogomips	: 3657.37
clflush size	: 64
power management:

virsh dumpxml SHCXP
<domain type='kvm'>
  <name>SHCXP</name>
  <uuid>7ea0f870-facd-e98b-6d01-2dcbbc4e2cc1</uuid>
  <memory>524288</memory>
  <currentMemory>524288</currentMemory>
  <vcpu>1</vcpu>
  <os>
    <type arch='i686' machine='pc'>hvm</type>
    <boot dev='hd'/>
  </os>
  <features>
    <pae/>
  </features>
  <clock offset='localtime'/>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>restart</on_reboot>
  <on_crash>restart</on_crash>
  <devices>
    <emulator>/usr/bin/qemu-kvm</emulator>
    <disk type='file' device='disk'>
      <source file='/var/lib/libvirt/images/SHCXP.img'/>
      <target dev='hda' bus='ide'/>
    </disk>
    <disk type='block' device='cdrom'>
      <source dev='/dev/sr0'/>
      <target dev='hdc' bus='ide'/>
      <readonly/>
    </disk>
    <interface type='network'>
      <mac address='54:52:00:42:a6:d3'/>
      <source network='default'/>
      <target dev='vnet0'/>
    </interface>
    <serial type='pty'>
      <target port='0'/>
    </serial>
    <console type='pty'>
      <target port='0'/>
    </console>
    <input type='tablet' bus='usb'/>
    <input type='mouse' bus='ps2'/>
    <graphics type='vnc' port='-1' autoport='yes'/>
    <sound model='es1370'/>
  </devices>
</domain>
Comment 4 Tim McConnell 2009-08-13 01:38:41 EDT
From ~/.virt-manager/virt-manager.log 

[Tue, 11 Aug 2009 23:05:50 virt-manager 3224] ERROR (proxies:400) Introspect error on :1.0:/org/freedesktop/Hal/devices/net_da_8e_b5_b0_7c_36: dbus.exceptions.DBusException: No device with id /org/freedesktop/Hal/devices/net_da_8e_b5_b0_7c_36
[Tue, 11 Aug 2009 23:05:50 virt-manager 3224] DEBUG (proxies:403) Executing introspect queue due to error
[Tue, 11 Aug 2009 23:05:50 virt-manager 3224] ERROR (connection:218) Exception in handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 214, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/share/virt-manager/virtManager/connection.py", line 170, in _net_phys_device_added
    if objif.QueryCapability("net"):
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
DBusException: org.freedesktop.Hal.NoSuchDevice: No device with id /org/freedesktop/Hal/devices/net_da_8e_b5_b0_7c_36
[Tue, 11 Aug 2009 23:05:55 virt-manager 3224] DEBUG (engine:324) window counter decremented to 1
[Tue, 11 Aug 2009 23:05:58 virt-manager 3224] DEBUG (engine:320) window counter incremented to 2
[Tue, 11 Aug 2009 23:06:08 virt-manager 3224] DEBUG (engine:491) Starting vm 'SHCXP'.
[Tue, 11 Aug 2009 23:06:11 virt-manager 3224] DEBUG (error:76) Uncaught Error: Error starting domain: internal error unable to start guest: qemu: could not open disk image /dev/sr0
 : Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 493, in run_domain
    vm.startup()
  File "/usr/share/virt-manager/virtManager/domain.py", line 573, in startup
    self.vm.create()
  File "/usr/lib/python2.6/site-packages/libvirt.py", line 287, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: internal error unable to start guest: qemu: could not open disk image /dev/sr0


[Tue, 11 Aug 2009 23:06:24 virt-manager 3224] DEBUG (engine:324) window counter decremented to 1
[Tue, 11 Aug 2009 23:07:19 virt-manager 3224] DEBUG (engine:218) Showing help for virt-manager-host-window
[Tue, 11 Aug 2009 23:10:53 virt-manager 3224] DEBUG (engine:320) window counter incremented to 2
[Tue, 11 Aug 2009 23:11:48 virt-manager 3224] DEBUG (engine:491) Starting vm 'SHCXP'.
[Tue, 11 Aug 2009 23:11:51 virt-manager 3224] DEBUG (error:76) Uncaught Error: Error starting domain: internal error unable to start guest: qemu: could not open disk image /dev/sr0
 : Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 493, in run_domain
    vm.startup()
  File "/usr/share/virt-manager/virtManager/domain.py", line 573, in startup
    self.vm.create()
  File "/usr/lib/python2.6/site-packages/libvirt.py", line 287, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: internal error unable to start guest: qemu: could not open disk image /dev/sr0


[Tue, 11 Aug 2009 23:11:51 virt-manager 3224] ERROR (proxies:400) Introspect error on :1.0:/org/freedesktop/Hal/devices/net_0e_c1_06_e0_32_8f: dbus.exceptions.DBusException: No device with id /org/freedesktop/Hal/devices/net_0e_c1_06_e0_32_8f
[Tue, 11 Aug 2009 23:11:51 virt-manager 3224] DEBUG (proxies:403) Executing introspect queue due to error
[Tue, 11 Aug 2009 23:11:51 virt-manager 3224] ERROR (connection:218) Exception in handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 214, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/share/virt-manager/virtManager/connection.py", line 170, in _net_phys_device_added
    if objif.QueryCapability("net"):
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
DBusException: org.freedesktop.Hal.NoSuchDevice: No device with id /org/freedesktop/Hal/devices/net_0e_c1_06_e0_32_8f
[Tue, 11 Aug 2009 23:11:55 virt-manager 3224] DEBUG (engine:324) window counter decremented to 1
[Tue, 11 Aug 2009 23:11:57 virt-manager 3224] DEBUG (engine:324) window counter decremented to 0
[Tue, 11 Aug 2009 23:11:57 virt-manager 3224] DEBUG (engine:332) Exiting app normally.
Comment 5 Mark McLoughlin 2009-08-14 13:49:16 EDT
(In reply to comment #4)

> libvirtError: internal error unable to start guest: qemu: could not open disk
> image /dev/sr0

Ah, that's a dup of bug #473154

To workaround the problem you use 'virsh edit SHCXP' to remove the "<source dev='/dev/sr0'/>" line

Thanks for the report

*** This bug has been marked as a duplicate of bug 473154 ***

Note You need to log in before you can comment on or make changes to this bug.