Bug 516770 - [RFE] scripts in kickstart-profile numbered instead of named
[RFE] scripts in kickstart-profile numbered instead of named
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: WebUI (Show other bugs)
0.6
All Linux
low Severity medium
: ---
: ---
Assigned To: Gennadii Altukhov
Jan Hutař
: FutureFeature
Depends On:
Blocks: spacewalk-rfe 1395887 space27
  Show dependency treegraph
 
Reported: 2009-08-11 09:15 EDT by Sandro Mathys
Modified: 2017-09-27 14:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1395887 (view as bug list)
Environment:
Last Closed: 2017-09-27 14:52:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sandro Mathys 2009-08-11 09:15:23 EDT
Description of problem:
In Systems > Kickstart > Profiles > Scripts, the scripts are numbered. It would be much better to have the ability to give the script a name to be able to identify it without viewing the script itself.

Version-Release number of selected component (if applicable):
# rpm -qa | grep spacewalk
spacewalk-search-0.6.11-1.el5
spacewalk-branding-0.6.8-1.el5
spacewalk-0.6.4-1.el5
spacewalk-html-0.6.19-1.el5
spacewalk-backend-0.6.30-1.el5
spacewalk-backend-config-files-0.6.30-1.el5
spacewalk-taskomatic-0.6.42-1.el5
spacewalk-schema-0.6.22-1.el5
rhn-org-httpd-ssl-key-pair-spacewalk-1.0-4
spacewalk-backend-xml-export-libs-0.6.30-1.el5
spacewalk-backend-package-push-server-0.6.30-1.el5
spacewalk-moon-0.6.19-1.el5
spacewalk-client-tools-0.0-1
spacewalk-java-config-0.6.42-1.el5
spacewalk-monitoring-0.6.7-1.el5
spacewalk-admin-0.6.3-1.el5
spacewalk-backend-server-0.6.30-1.el5
spacewalk-backend-app-0.6.30-1.el5
spacewalk-backend-iss-export-0.6.30-1.el5
spacewalk-backend-xp-0.6.30-1.el5
spacewalk-pxt-0.6.19-1.el5
spacewalk-cypress-0.6.19-1.el5
spacewalk-selinux-0.6.13-1.el5
spacewalk-java-lib-0.6.42-1.el5
spacewalk-backend-sql-0.6.30-1.el5
spacewalk-backend-xmlrpc-0.6.30-1.el5
spacewalk-backend-config-files-tool-0.6.30-1.el5
spacewalk-backend-iss-0.6.30-1.el5
spacewalk-base-0.6.19-1.el5
spacewalk-sniglets-0.6.19-1.el5
spacewalk-certs-tools-0.6.3-1.el5
spacewalk-doc-indexes-0.6.1-1.el5
spacewalk-config-0.6.13-1.el5
spacewalk-base-minimal-0.6.19-1.el5
spacewalk-backend-config-files-common-0.6.30-1.el5
spacewalk-backend-applet-0.6.30-1.el5
spacewalk-grail-0.6.19-1.el5
spacewalk-monitoring-selinux-0.6.12-1.el5
spacewalk-backend-tools-0.6.30-1.el5
spacewalk-java-0.6.42-1.el5
spacewalk-setup-0.6.21-1.el5

How reproducible:
Always

Steps to Reproduce:
1. Systems > Kickstart > Profiles > Scripts
2. add new kickstart script
3. see the list, column "Script #"
  
Actual results:
Automatic numbering: Script 1, Script 2, Script 3

Expected results:
Possibility to give names which are then shows instead of the script#.

Additional info:
Comment 1 Sandro Mathys 2009-11-19 04:05:18 EST
This ticket is also applicable to RHN Satellite 5.3.0.
Comment 2 Jan Pazdziora 2010-11-19 11:05:21 EST
Mass-moving to space13.
Comment 3 Miroslav Suchý 2011-04-11 03:34:01 EDT
We did not have time for this one during Spacewalk 1.4 time frame. Mass moving to Spacewalk 1.5.
Comment 4 Miroslav Suchý 2011-04-11 03:37:23 EDT
We did not have time for this one during Spacewalk 1.4 time frame. Mass moving to Spacewalk 1.5.
Comment 5 Jan Pazdziora 2011-07-20 07:52:31 EDT
Aligning under space16.
Comment 6 Gennadii Altukhov 2016-05-09 06:18:26 EDT
Looks like fixed in spacewalk.git:
be7996f4740fd642b1c92068ac96b8abfbd1f1b4
Comment 7 Jan Hutař 2016-11-10 17:35:12 EST
Stagred `cdn-sync -c rhel-x86_64-server-6` on two SWnightly installs. Will try to create kickstarts and some scripts tomorrow (I hope).
Comment 8 Jan Hutař 2016-11-15 16:20:30 EST
Tested on SW@RHEL6@Oracle with spacewalk-java-2.6.47-1.el6.noarch.

Scripts now can have names and can be reordered => VERIFIED
Comment 9 Eric Herget 2017-09-27 14:52:51 EDT
This looks like it was fixed in 2.6.  I'm marking it closed -> currentrelease for the 2.7 release.

https://github.com/spacewalkproject/spacewalk/wiki/ReleaseNotes27

Note You need to log in before you can comment on or make changes to this bug.