Bug 516807 - Error message in bluetooth transfers is hardly readable
Error message in bluetooth transfers is hardly readable
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-bluetooth (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fitandfinish
  Show dependency treegraph
 
Reported: 2009-08-11 11:15 EDT by Kamil Páral
Modified: 2010-06-18 09:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-18 09:14:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dialog.png (14.67 KB, image/png)
2009-08-11 11:15 EDT, Kamil Páral
no flags Details
dialog2.png (18.18 KB, image/png)
2009-08-11 11:16 EDT, Kamil Páral
no flags Details
xsession-errors (4.16 KB, text/plain)
2009-08-11 11:59 EDT, Kamil Páral
no flags Details
full error (20.10 KB, image/png)
2009-08-11 12:22 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2009-08-11 11:15:54 EDT
Created attachment 357036 [details]
dialog.png

Description of problem:
When you get an error during bluetooth transfer to your phone, it is very hardly readable, because it is cut off. See dialog.png. You can enlarge it, but you need veeery large display if you want to read it all (depending on the message text). See dialog2.png.

Version-Release number of selected component (if applicable):
gnome-bluetooth-2.27.9-2.fc12.x86_64
current rawhide taken from
https://fedoraproject.org/wiki/Test_Day:2009-08-11_Fit_and_Finish:Peripherals

How reproducible:
always
 
Actual results:
Cut off message

Expected results:
Readable message, automatically aligning into multiple rows if needed.
Comment 1 Kamil Páral 2009-08-11 11:16:14 EDT
Created attachment 357037 [details]
dialog2.png
Comment 2 Kamil Páral 2009-08-11 11:59:43 EDT
Created attachment 357041 [details]
xsession-errors

I have some logs for the displayed error and I attach them here. However I will not report a new bug about it, because it is black magic - sometimes it works and sometimes not, and I am not able to find a pattern.

$ bluetooth-properties -d
Adapter: (null) (00:24:2C:BB:AA:28)
	Default adapter
	Is discovering

Device: Ripper-phone (00:1C:A4:81:90:F2)
	Type: Phone Icon: phone
	Paired: True Trusted: True Connected: True
	Services: org.bluez.Input (not connected) 
	UUIDs: SyncMLClient SerialPort DialupNetworking IrMCSync OBEXObjectPush OBEXFileTransfer Headset_-_AG NAP HandsfreeAudioGateway HumanInterfaceDeviceService
Comment 3 Kamil Páral 2009-08-11 12:22:12 EDT
Created attachment 357043 [details]
full error
Comment 4 Bastien Nocera 2009-09-16 09:42:23 EDT
There's 2 bugs. One is that the sending didn't work, the other that the error message ends up being truncated.
Comment 5 Bastien Nocera 2009-09-16 10:50:39 EDT
Filed upstream bug:
https://bugzilla.gnome.org/show_bug.cgi?id=595374
about the message being truncated.

As for the actual bug of it not sending the file, how do you reproduce the bug?
Can you kill the running obex-client (if any), and run it by hand before sending the file? (it lives in /usr/libexec/)
What's the version of obexd?

The output of obex-client would help debugging this problem.
Comment 6 Bug Zapper 2009-11-16 06:20:48 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Kamil Páral 2010-03-19 07:36:25 EDT
I have not managed to trigger the obex error in Fedora 13. I assume it works now ok.

As for the error formatting issues (which is this bug about), the upstream bug [1] has been marked as fixed, so I assume this one can be closed too.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=595374
Comment 8 Bastien Nocera 2010-06-18 09:14:34 EDT
Cool, closing then.

Note You need to log in before you can comment on or make changes to this bug.