This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 516957 - TypeError: exceptions must be classes or instances, not NotImplementedType
TypeError: exceptions must be classes or instances, not NotImplementedType
Status: CLOSED DUPLICATE of bug 520232
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-08-11 22:39 EDT by John Reiser
Modified: 2009-09-03 03:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-03 03:49:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2009-08-11 22:39:51 EDT
Description of problem: From out of the blue (not in response to any known user command) a dialog box appears on the desktop "An internal system error has occurred.  A problem that we were not expecting has occurred.  Please report htis bug in your distribution bugtracker with the error description."  There is no readily-identifiable process associated with the dialog.  There is a scroll box "More details" whose contents I will copy+paste below.


Version-Release number of selected component (if applicable):
PackageKit-0.5.1-1.fc12.i686
yum-3.2.23-13.fc12.noarch


How reproducible: unknown; happened twice in same session, a few minutes apart.


Steps to Reproduce:
1. login, run "yum update" (updates anaconda and pungi) and finish yum, wait a couple minutes
2.
3.
  
Actual results:  Dialog box as in Description, with "More details":
-----
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1195, in _commonLoadRepoXML
    result = self._getFileRepoXML(local, text)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 976, in _getFileRepoXML
    cache=self.http_caching == 'all')
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 754, in _getFile
    result = self.mediafunc(local = local, checkfunc = checkfunc, relative = relative, text = text, copy_local = copy_local, url = url, mediaid = self.mediaid, name = self.name, discnum = discnum, range = (start, end))
  File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 2863, in MediaGrabber
    manager = MediaManager()
  File "/usr/share/PackageKit/helpers/yum/yumMediaManager.py", line 101, in __init__
    raise NotImplemented
TypeError: exceptions must be classes or instances, not NotImplementedType
-----

Expected results: no dialog box complaining of mysterious error


Additional info:
Comment 1 Steven M. Parrish 2009-08-26 15:12:36 EDT
Please upgrade to the latest PackageKit in rawhide and report if this is still an issue.

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Steve Chapel 2009-08-27 23:10:19 EDT
I'm having the same problem, and yum info PackageKit reports:

Loaded plugins: refresh-packagekit
Installed Packages
Name       : PackageKit
Arch       : x86_64
Version    : 0.5.2
Release    : 0.1.20090824git.fc12
Size       : 1.7 M
Repo       : installed
From repo  : rawhide
...
Comment 3 Richard Hughes 2009-09-03 03:49:35 EDT

*** This bug has been marked as a duplicate of bug 520232 ***

Note You need to log in before you can comment on or make changes to this bug.