This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 516958 - default viewvc.conf changed, paths need fixing
default viewvc.conf changed, paths need fixing
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: viewvc (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Bojan Smojver
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-11 22:42 EDT by Zing
Modified: 2009-08-12 16:55 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.1.2-2.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-12 16:55:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Zing 2009-08-11 22:42:06 EDT
Description of problem:
In viewvc-1.1.2-1.fc11, some of the default viewvc.conf paths aren't "fixed" anymore.  I think the main cause is that the viewvc.conf from the tar file has changed and the perl substitutions aren't working anymore. For example, template_dir in the default installed viewvc.conf will be commented out and will cause a python traceback because it will look for the templates in /etc/viewvc/templates/...  which doesn't exist.

template_dir/cvsgraph_conf/use_cvsgraph config variables all need that # sign like how docroot is substituted in the spec file.  I didn't test it, but it looks like that should fix it.


Version-Release number of selected component (if applicable):
viewvc-1.1.2-1.fc11  <--- a recent testing release
Comment 1 Bojan Smojver 2009-08-11 22:56:54 EDT
Thanks for pointing it out. Fixing now.
Comment 2 Bojan Smojver 2009-08-11 23:12:33 EDT
I just built a new package for F-11, but the updates admin system just went down. The build is here:

http://koji.fedoraproject.org/koji/buildinfo?buildID=126941
Comment 3 Fedora Update System 2009-08-11 23:27:45 EDT
viewvc-1.1.2-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/viewvc-1.1.2-2.fc11
Comment 4 Fedora Update System 2009-08-12 16:55:15 EDT
viewvc-1.1.2-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.