Bug 516986 - Webcam Z-Star Microelectronics doesn't work
Webcam Z-Star Microelectronics doesn't work
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks: fitandfinish
  Show dependency treegraph
 
Reported: 2009-08-12 04:13 EDT by Kamil Páral
Modified: 2010-01-05 07:20 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-05 07:20:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rawhide non-working logs (15.76 KB, text/plain)
2009-08-12 04:13 EDT, Kamil Páral
no flags Details
ubuntu working logs (16.02 KB, text/plain)
2009-08-12 04:13 EDT, Kamil Páral
no flags Details
debug-bad.log (62.92 KB, text/plain)
2009-08-17 06:47 EDT, Kamil Páral
no flags Details
debug-modified.log (71.42 KB, text/plain)
2009-08-17 06:48 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2009-08-12 04:13:10 EDT
Created attachment 357126 [details]
rawhide non-working logs

Description of problem:
USB webcam Z-Star Microelectronics doesn't work. When connected it is detected by kernel by Cheese program will not display any output. The same webcam works with Cheese in Ubuntu 9.04.

Version-Release number of selected component (if applicable):
Doesn't work:
current Rawhide from 2009-08-11 testday: https://fedoraproject.org/wiki/Test_Day:2009-08-11_Fit_and_Finish:Peripherals
Fedora 11
Works:
Ubuntu 9.04

How reproducible:
always

Steps to Reproduce:
1. Connect camera
2. Start cheese
3. No image received
  
Additional info:
See attachments for log files from Rawhide and from Ubuntu.
Comment 1 Kamil Páral 2009-08-12 04:13:31 EDT
Created attachment 357127 [details]
ubuntu working logs
Comment 2 Hans de Goede 2009-08-12 05:19:22 EDT
Hi,

Ok I think I've got an idea what is going on here.

For starters can you please with F-11 or the testday livecd do:
echo 199 > /sys/module/gspca_main/parameters/debug

Unplug, replug and then do:
dmesg > debug-bad.log

And attach debug-bad.log here ?

Can you then please follow these instructions:
http://hansdegoede.livejournal.com/6630.html

But before doing "make", edit "linux/drivers/media/video/gspca/zc3xx.c", find this line (near the end of the file):
        {USB_DEVICE(0x0ac8, 0x0302), .driver_info = SENSOR_PAS106},
And remove the ".driver_info = SENSOR_PAS106" part of it ?

Here you can use either F-11 or the testday live CD installed to disk, whatever is easier.

If my hunch is right, this should get your webcam working. After which I will need more help from you to find a way to make this work without removing the
".driver_info = SENSOR_PAS106" as that will probably break other cams with the
same usb-id.

Can you then (after rebooting) again do:
echo 199 > /sys/module/gspca_main/parameters/debug

Unplug, replug and then do:
dmesg > debug-modified.log

And attach debug-modified.log here too?


Thanks,

Hans
Comment 3 Kamil Páral 2009-08-13 09:56:43 EDT
I will help with this bug in a few days, first I have to find out how to resize LUKS+LVM partition in order to have place to install rawhide.
Comment 4 Hans de Goede 2009-08-13 13:41:52 EDT
(In reply to comment #3)
> I will help with this bug in a few days, first I have to find out how to resize
> LUKS+LVM partition in order to have place to install rawhide.  

Ok,

Note you can do the necessary testing with F-11 (or F-10 for that matter) too,
the instructions from here:
http://hansdegoede.livejournal.com/6630.html

Basically replace your entire video4linux subsystem (which is why the reboot
is needed).

Regards,

Hans
Comment 5 Kamil Páral 2009-08-17 06:47:59 EDT
Created attachment 357626 [details]
debug-bad.log

Hello:

1) debug-bad.log is attached
2) make menuconfig requires also ncurses-devel, which you may want to add to your blog
3) after making requested changes the webcam works
4) debug-modified.log is attached
Comment 6 Kamil Páral 2009-08-17 06:48:19 EDT
Created attachment 357627 [details]
debug-modified.log
Comment 7 Kamil Páral 2009-08-24 08:55:25 EDT
Hans, how is it possible that it works in one distribution and doesn't work in another? Don't they use the same project (gspca) for accessing the camera?
Comment 8 Hans de Goede 2009-08-24 09:05:04 EDT
(In reply to comment #7)
> Hans, how is it possible that it works in one distribution and doesn't work in
> another? Don't they use the same project (gspca) for accessing the camera?  

Kamil,

Ubuntu has an older version which does not have the .driver_info = SENSOR_PAS106,
present for the usb-id of your camera, so the Ubuntu version will never do the pas105 probe, which seems to mess up detection of your sensor.

I'm afraid it will stop working in the next Ubuntu version too.
Comment 9 Bug Zapper 2009-11-16 06:21:37 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Hans de Goede 2009-12-20 04:26:48 EST
Hi Kamil,

Sorry for the long silence, it looks like the upstream zc3xx maintainer has committed a fix which may fix this, can you please try:

yum install mercurial
hg clone http://linuxtv.org/hg/~jfrancois/gspca
cd gspca
make menuconfig
<choose exit>
make
sudo make install
reboot

And then try the webcam in question again? Thanks!
Comment 11 Kamil Páral 2010-01-05 06:21:37 EST
Perfect, it works now.
Comment 12 Hans de Goede 2010-01-05 07:20:21 EST
(In reply to comment #11)
> Perfect, it works now.  

That is good news! I'm closing this then with a resolution of upstream, the upstream change should find its way to a Fedora kernel within a couple of months.

Note You need to log in before you can comment on or make changes to this bug.