Bug 517088 - Bluez kills USB mice
Bluez kills USB mice
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-12 11:22 EDT by Justin Phelps
Modified: 2009-10-03 15:03 EDT (History)
8 users (show)

See Also:
Fixed In Version: 4.42-6.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-03 15:03:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
All my logs (1.21 MB, application/x-gzip)
2009-08-12 17:26 EDT, Justin Phelps
no flags Details

  None (edit)
Description Justin Phelps 2009-08-12 11:22:17 EDT
Description of problem:
When upgrading to the latest bluez packages

bluez.i586                            4.42-3.fc11                        updates
bluez-cups.i586                       4.42-3.fc11                        updates
bluez-libs.i586                       4.42-3.fc11                        updates


My USB mouse stops functioning. It is not a hardware issue because when I downgrade the packages, my mouse functions perfectly.

How reproducible:
Upgrade the bluetooth utilities, reboot, and see the mouse isn't working.

Actual results:
Mouse doesn't work.

Expected results:
Bluetooth shouldn't interfere with USB mice.

Additional info:
Let me know what you need in addition to the following:

$ lsusb
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 0a5c:2145 Broadcom Corp. 
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 17ef:1004 Lenovo 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 004: ID 413c:3010 Dell Computer Corp. Optical Wheel Mouse
Bus 003 Device 003: ID 413c:2005 Dell Computer Corp. RT7D50 Keyboard
Bus 003 Device 002: ID 03eb:0902 Atmel Corp. 4-Port Hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Comment 1 Bastien Nocera 2009-08-12 13:32:49 EDT
It's not a USB mice, it's a wireless mouse with a HID proxy dongle.

The dongle is being switched to Bluetooth on startup. Check /etc/udev/rules.d/bluetooth-hid2hci.rules
Comment 2 Justin Phelps 2009-08-12 14:11:07 EDT
Um, it is a usb mouse. It has a wire. It is not cordless. I know what kind of mouse I have.

Regardless, this file does not exist on my system: /etc/udev/rules.d/bluetooth-hid2hci.rules
Comment 3 Bastien Nocera 2009-08-12 16:42:10 EDT
Then, if that's not it, I'd need a kernel log or *anything* to know what's happening. Because this is certainly the first report of the kind I get...
Comment 4 Justin Phelps 2009-08-12 17:26:35 EDT
Created attachment 357243 [details]
All my logs

All the logs from my system.
Comment 5 Aram Agajanian 2009-08-13 17:27:31 EDT
I have experienced this bug also with a Dell USB corded mouse.  The USB ID for the mouse is 413c:3010.

By the way, the next-generation Dell USB corded mouse (0461:4d15) is not affected by this bug.

Reverting to 4.42-1 fixes the problem.

The following thread from the Ubuntu forum for 9.10 indicates that a subsequent update fixed the problem for them.  It doesn't say what the update was.  Perhaps, it was a newer version of bluez.

http://ubuntuforums.org/showthread.php?t=1177862
Comment 7 Dennis Björklund 2009-08-21 02:58:31 EDT
I have the same problem. Updated and then my mouse didn't work anymore. Reverted to bluez-4.42-1.fc11 and it worked again. I have a Dell corded optical usb mouse (like Aram above).

When I disconnect and reconnect the mouse these log lines are generated:

-- /var/log/messages

Aug 21 08:04:05 olle kernel: usb 2-1: USB disconnect, address 2
Aug 21 08:04:06 olle kernel: usb 2-1: new low speed USB device using uhci_hcd and address 4
Aug 21 08:04:07 olle kernel: usb 2-1: New USB device found, idVendor=413c, idProduct=3010
Aug 21 08:04:07 olle kernel: usb 2-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
Aug 21 08:04:07 olle kernel: usb 2-1: configuration #1 chosen from 1 choice
Aug 21 08:04:07 olle kernel: input: HID 413c:3010 as /devices/pci0000:0 /0000:00:1d.0/usb2/2-1/2-1:1.0/input/input13
Aug 21 08:04:07 olle kernel: generic-usb 0003:413C:3010.0003: input,hidraw0: USB HID v1.10 Mouse [HID 413c:3010] on usb-0000:00:1d.0-1/input0

-- /var/log/Xorg.0.log

(II) config/hal: Adding input device HID 413c:3010
(**) HID 413c:3010: always reports core events
(**) HID 413c:3010: Device: "/dev/input/event12"
(EE) Unable to open evdev device "/dev/input/event12".
(II) UnloadModule: "evdev"
(EE) PreInit returned NULL for "HID 413c:3010"
(EE) config/hal: NewInputDeviceRequest failed (8)
Comment 8 Dennis Björklund 2009-08-31 00:33:50 EDT
Bastien, is there more information needed? In comment #3 you said you wanted a kernel log or anything. If you need something special I will try to provide it.
Comment 9 Norman Gaywood 2009-08-31 01:05:43 EDT
Just want to add my METOO to this. I have the same mouse and it to goes away when I update bluez. Comes back when I down grade.
Comment 10 Dennis Björklund 2009-09-03 02:34:22 EDT
I got the mouse working again by editing

/etc/udev/rules.d/bluetooth-hid2hci.rules

and removing the rule

ACTION=="add", ENV{ID_VENDOR}=="413c", ENV{ID_CLASS}=="mouse", ATTRS{bmAttributes}=="e0", KERNEL=="mouse*", RUN+="/usr/sbin/hid2hci --method dell -v $env{ID_VENDOR} -p $env{ID_MODEL} --mode hid"

Seems like that rule match devices it shouldn't match.
Comment 11 Fedora Update System 2009-09-16 06:15:24 EDT
bluez-4.42-6.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/bluez-4.42-6.fc11
Comment 12 Fedora Update System 2009-09-16 16:34:54 EDT
bluez-4.42-6.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bluez'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9680
Comment 13 Fedora Update System 2009-10-03 15:03:27 EDT
bluez-4.42-6.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.