Bug 517146 - Deletion of org does not result in deletion of associated Kickstart profiles from Cobbler
Deletion of org does not result in deletion of associated Kickstart profiles ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
All Linux
high Severity high
: ---
: ---
Assigned To: Stephen Herr
Dimitar Yordanov
:
: 837796 (view as bug list)
Depends On:
Blocks: sat560-provisioning
  Show dependency treegraph
 
Reported: 2009-08-12 14:31 EDT by Steve Salevan
Modified: 2013-10-01 17:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 880346 (view as bug list)
Environment:
Last Closed: 2013-10-01 17:39:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Salevan 2009-08-12 14:31:39 EDT
Description of problem:
If a user deletes an org from their Satellite, the Kickstart profiles that they have created will not be deleted from Cobbler, and can be viewed from another org.

Version-Release number of selected component (if applicable):
530, Stage build

How reproducible:
Always

Steps to Reproduce:
1. Create an org and grant it provisioning entitlements
2. Create several kickstart profiles under this org
3. Delete this org
4. Create another org and grant it provisioning entitlements
5. Login as the orgadmin for this new org
  
Actual results:
Old org's profiles can be viewed from the SDC of any Provisioning-entitled system

Expected results:
Old org's profiles cannot be viewed from the SDC of any Provisioning-entitled system

Additional info:
Comment 5 Tasos Papaioannou 2010-10-21 09:49:53 EDT
Appears to be due to the fact that an orphaned cfg file is left behind after deletion of the first org's kickstart profile:

# ll /var/lib/rhn/kickstarts/wizard
[...]
-rw-r--r-- 1 tomcat tomcat  8081 Oct 21 09:01 bz-517146-ks--43.cfg

^ cfg file for ks profile from deleted org #43.

In the new org, this cfg file shows up as a non-Satellite-managed kickstart profile. The associated ks profile data in the database has been deleted; it's just the cfg file that needs to be deleted.
Comment 6 Stephen Herr 2012-11-21 14:29:54 EST
*** Bug 837796 has been marked as a duplicate of this bug. ***
Comment 7 Stephen Herr 2012-11-26 13:45:17 EST
No, this is actually due to the fact that the Cobbler profiles are not removed when the Org is deleted.

$ cobbler profile list
Comment 11 Clifford Perry 2013-10-01 17:39:19 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.