Bug 517214 - readahead seems to be reading lots of files
readahead seems to be reading lots of files
Status: CLOSED DUPLICATE of bug 470680
Product: Fedora
Classification: Fedora
Component: readahead (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-12 21:53 EDT by William Lovaton
Modified: 2009-08-13 07:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-13 07:48:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attaching /var/lib/readahead/early.sorted (35.05 KB, text/plain)
2009-08-12 21:54 EDT, William Lovaton
no flags Details

  None (edit)
Description William Lovaton 2009-08-12 21:53:42 EDT
As suggested here:
https://bugzilla.redhat.com/show_bug.cgi?id=513448#c14

I'm creating this new bug report.

This is an up to date Fedora 11 system with no third party drivers, the relevant packages are:

kernel-PAE-2.6.29.6-217.2.3.fc11.i686
glibc-2.10.1-4.i686
readahead-1.4.9-1.fc11.i586

This bug is slowing down the boot process a lot!.

The only extra services I have on by default is httpd and libvirtd which I use as part of my web development process.  As others bug reports seem to suggest, libvirt is confusing readahead slowing down the boot process.  These are my disk images in libvirtd:

-rw-------. 1 root root 3,0G ago 10 21:46 Win2000.img
-rw-------. 1 root root  18G ago  9 23:26 WinVista.img
-rw-------. 1 root root 4,0G ago 11 21:43 WinXP.img
Comment 1 William Lovaton 2009-08-12 21:54:35 EDT
Created attachment 357261 [details]
Attaching /var/lib/readahead/early.sorted
Comment 2 Harald Hoyer 2009-08-13 05:41:42 EDT
Ok, you might edit /etc/readahead.conf and add /var to RAC_EXCLUDE.

Then remove /var/lib/readahead/*.* and turn readahead back on in /etc/sysconfig/readahead.

The next readahead will exclude /var completely. 

Thanks for your report!
Comment 3 Harald Hoyer 2009-08-13 07:48:18 EDT

*** This bug has been marked as a duplicate of bug 470680 ***

Note You need to log in before you can comment on or make changes to this bug.