Bug 517218 - wrong dependencies (64bit) is needed
Summary: wrong dependencies (64bit) is needed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sugar-pippy
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Fabian Affolter
QA Contact: Fedora Extras Quality Assurance
URL: http://pastebin.be/20323
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-13 03:57 UTC by pleabargain
Modified: 2014-01-21 23:10 UTC (History)
9 users (show)

Fixed In Version: 34-3.fc10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-01 18:04:26 UTC
Type: ---


Attachments (Terms of Use)

Description pleabargain 2009-08-13 03:57:32 UTC
Description of problem:
we set up a rawhide chroot today with febootstrap on f11 and tried to run "yum groupinstall sugar-desktop"

Version-Release number of selected component (if applicable):


How reproducible:
someone else on IRC reproduced similar

Steps to Reproduce:
1.
2.
3.
  
Actual results:
see http://pastebin.be/20323

Expected results:


Additional info:

Comment 1 Bernie Innocenti 2009-08-13 04:03:55 UTC
It's caused by:

bernie@giskard:~/src/fedora/sugar-pippy/F-11$ rpm -qp --requires sugar-pippy-34-2.fc11.i386.rpm | grep 64bit
libc.so.6()(64bit)  
libc.so.6(GLIBC_2.2.5)(64bit)  
libgcc_s.so.1()(64bit)  
libgcc_s.so.1(GCC_3.0)(64bit)  
libm.so.6()(64bit)  
libm.so.6(GLIBC_2.2.5)(64bit)  
libstdc++.so.6()(64bit)  
libstdc++.so.6(CXXABI_1.3)(64bit)  
libstdc++.so.6(GLIBCXX_3.4)(64bit)  

Which, in turn, is caused by:

 file /usr/share/sugar/activities/Pippy.activity/library/pippy/physics/box2d
 /box2d_linux64/_Box2D2.so: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped

Comment 2 Bernie Innocenti 2009-08-13 04:50:27 UTC
There are two binary _Box2D2.so files in the upstream *source* packages:

 Pippy-34/library/pippy/physics/box2d/box2d_linux32/_Box2D2.so
 Pippy-34/library/pippy/physics/box2d/box2d_linux64/_Box2D2.so

These must be removed for the package to comply with the Fedora packaging
guidelines and common sense.

But first we need to figure out where the actual sources went.  They're not even in git:

http://dev.laptop.org/git/projects/pippy-activity/tree/library/pippy/physics/box2d

Comment 3 Fabian Affolter 2009-08-13 12:39:46 UTC
The source is now hosted by Sugarlabs

http://download.sugarlabs.org/sources/sucrose/fructose/Pippy/

Comment 4 Fedora Update System 2009-08-13 21:15:36 UTC
sugar-pippy-34-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/sugar-pippy-34-3.fc11

Comment 5 Fedora Update System 2009-08-13 21:15:41 UTC
sugar-pippy-34-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/sugar-pippy-34-3.fc10

Comment 6 Fedora Update System 2009-08-15 08:07:12 UTC
sugar-pippy-34-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update sugar-pippy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-8518

Comment 7 Fedora Update System 2009-08-15 08:28:08 UTC
sugar-pippy-34-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update sugar-pippy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8623

Comment 8 Fedora Update System 2009-09-01 18:04:20 UTC
sugar-pippy-34-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2009-09-01 18:08:51 UTC
sugar-pippy-34-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.