Bug 517289 - [PATCH] Fix virt-manager addhardware.py hostdev error handling
[PATCH] Fix virt-manager addhardware.py hostdev error handling
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
11
All Linux
high Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11VirtTarget
  Show dependency treegraph
 
Reported: 2009-08-13 07:48 EDT by Paul W. Frields
Modified: 2009-09-14 12:05 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-14 12:05:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for gettext problem (542 bytes, patch)
2009-08-13 07:48 EDT, Paul W. Frields
no flags Details | Diff

  None (edit)
Description Paul W. Frields 2009-08-13 07:48:26 EDT
Created attachment 357305 [details]
Patch for gettext problem

libvirt-0.6.2-13.fc11

When trying to add a piece of hardware that's invalid (such as an iPhone via USB), virt-manager generates a traceback instead of an error dialog.  The attached patch fixes the problem.

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/addhardware.py", line 288, in forward
    if(self.validate(notebook.get_current_page()) != True):
  File "/usr/share/virt-manager/virtManager/addhardware.py", line 966, in validate
    str(e)))
TypeError: gettext() takes exactly 2 arguments (3 given)
Comment 1 Daniel Veillard 2009-08-13 07:58:34 EDT
Thanks for the patch but it looks like a fix fir virt-manager :-)

Daniel
Comment 2 Mark McLoughlin 2009-08-14 14:45:56 EDT
Patch looks good to me and is needed upstream/F-12 as well as F-11
Comment 3 Cole Robinson 2009-09-14 12:05:41 EDT
Thanks for the patch, applied upstream:

http://hg.et.redhat.com/cgi-bin/hg-virt.cgi/applications/virt-manager--devel/rev/d34def55dbd7

Fixed in virt-manager-0.8.0-3.fc12

Note You need to log in before you can comment on or make changes to this bug.