Bug 517310 - Printer test page wrong right margin
Summary: Printer test page wrong right margin
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: evince
Version: 6.0
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Marek Kašík
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-13 13:16 UTC by Tomas Pelka
Modified: 2010-03-12 11:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-12 11:15:51 UTC


Attachments (Terms of Use)
Canon ppd (203.20 KB, application/octet-stream)
2009-08-13 13:17 UTC, Tomas Pelka
no flags Details
Test page as PostScript (857.11 KB, application/octet-stream)
2009-08-13 13:49 UTC, Tim Waugh
no flags Details
Printed by evince (291.21 KB, image/tiff)
2009-08-13 14:42 UTC, Tomas Pelka
no flags Details
Printed by lp (304.03 KB, image/tiff)
2009-08-13 14:46 UTC, Tomas Pelka
no flags Details
original test page (56.72 KB, image/tiff)
2009-08-13 14:53 UTC, Tomas Pelka
no flags Details

Description Tomas Pelka 2009-08-13 13:16:17 UTC
Description of problem:
The right margin of printer test page isn't printed on our Canon iR 3170C EUR.

Version-Release number of selected component (if applicable):
cups-1.4-0.b2.18.fc11.x86_64.rpm

How reproducible:
100%

Steps to Reproduce:
1. Start system-config-printer.
2. Try to print test page.
3. watch printed test page.
  
Actual results:
No right margin.

Expected results:
All margin should be present.

Additional info:

Comment 1 Tomas Pelka 2009-08-13 13:17:35 UTC
Created attachment 357317 [details]
Canon ppd 

Canon iR 3170C EUR ppd.

Comment 3 Tim Waugh 2009-08-13 13:49:40 UTC
Created attachment 357322 [details]
Test page as PostScript

So if you print this file like 'lp -oraw output.ps' do you also have a missing right-hand edge border?

The relevant parts of the PPD are:

*DefaultImageableArea: A4
*ImageableArea A4/A4: "11.3386 11.3386 583.6614 830.6614"

The relevant parts of the PostScript are:

11.3 11.3 translate
gsave 2 setlinewidth 1 1 570.3 817.3 rectstroke grestore

This is what I got from the bannertops filter that comes with cups-1.4-0.rc1.12.fc12, and the numbers do seem to add up:

11.3 (left margin) + 570.3 (imageable width) + 2 (line width) == 583.6
583.6 (right-hand extent of image) <= 583.6614 (right-hand extend of imageable area)

Comment 4 RHEL Product and Program Management 2009-08-13 14:03:59 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 5 Tomas Pelka 2009-08-13 14:42:32 UTC
Created attachment 357328 [details]
Printed by evince

This was printed by evince.

Comment 6 Tomas Pelka 2009-08-13 14:46:48 UTC
Created attachment 357329 [details]
Printed by lp

This was printed by lp -oraw output.ps

Comment 7 Tomas Pelka 2009-08-13 14:53:40 UTC
Created attachment 357331 [details]
original test page

This is the original page, please. (Media Limits and Media Dimensions are different.)

Comment 8 Tim Waugh 2009-08-13 16:21:27 UTC
No surprise that evince gets printing wrong. ;-)  Changing component.

Comment 9 Tim Waugh 2009-08-13 16:22:37 UTC
Er.. you printed that test page for the wrong size page (US Letter instead of A4).

Comment 10 Tomas Pelka 2009-08-14 08:12:18 UTC
(In reply to comment #9)
> Er.. you printed that test page for the wrong size page (US Letter instead of
> A4).  

OMG Tim you are right, sorry for my stupidity.

Closing as NOTABUG.

Comment 11 Tim Waugh 2009-08-14 09:04:51 UTC
Well, the evince-printed test page came out wrong even though it was exactly the same as the command-line-printed A4 page which came out perfectly.

So there is still a bug here because evince is translating the page upwards and slightly to the right -- rather than just sending the PostScript directly to CUPS, which is what it ought to do.

Comment 12 Tomas Pelka 2009-08-14 09:35:36 UTC
(In reply to comment #11)
> Well, the evince-printed test page came out wrong even though it was exactly
> the same as the command-line-printed A4 page which came out perfectly.
> 

I think that fault was on my site, because I've print this page with US page format instead of A4 format (different dimensions - 216x279mm[US] vs 210x297mm[A4]).

When I print this page as A4, than all is fine.

> So there is still a bug here because evince is translating the page upwards and
> slightly to the right -- rather than just sending the PostScript directly to
> CUPS, which is what it ought to do.

Comment 13 Marek Kašík 2009-10-06 14:38:48 UTC
Hi,

this is a problem in libspectre. It was introduced into evince since upstream's fix of "https://bugzilla.gnome.org/show_bug.cgi?id=585442".
This change involved Ghostscript into processing of PS files.
libspectre doesn't set a paper size and that is why Ghostscript uses default paper size (US Letter).
The translation problem is also caused by this change because revert of the change in evince returns correct results.

=> reassigning to libspectre

Marek

Comment 14 Marek Kašík 2010-03-11 12:28:21 UTC
Hi,

the problem was really in evince. It should be fixed in current version of evince.
Tomas, could you try whether it works for you know?

Thanks

Marek

Comment 15 Tomas Pelka 2010-03-12 11:15:51 UTC
All is OK.

Verified on: evince-2.28.2-5.el6.x86_64

Thanks


Note You need to log in before you can comment on or make changes to this bug.