Bug 517315 - a2x fails to find fop.sh
Summary: a2x fails to find fop.sh
Keywords:
Status: CLOSED DUPLICATE of bug 283351
Alias: None
Product: Fedora
Classification: Fedora
Component: asciidoc
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Chris Wright
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-13 13:26 UTC by Michael Ploujnikov
Modified: 2009-08-13 13:29 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-13 13:29:52 UTC


Attachments (Terms of Use)

Description Michael Ploujnikov 2009-08-13 13:26:50 UTC
Description of problem:
I just installed asciidoc and tried to generate a PDF from a simple .txt file, but a2x failed because it couldn't find fop.sh. This continued to happen even after I additionally installed the fop package.

Version-Release number of selected component (if applicable):
asciidoc-8.2.5-4.fc11.noarch
fop-0.95-3.noarch


How reproducible:
Always.

Steps to Reproduce:
1. install asciidoc
2. create a simple asciidoc source file
3. try generating a PDF with a2x
4. install fop
5. re-try generating a PDF with a2x
  
Actual results:
$ sudo yum install asciidoc
...
$ echo "Title
> =====
> 
> Blah" > /tmp/test.txt
$ a2x -v -f pdf /tmp/test.txt
a2x: failed: cannot find required program: fop.sh
$ sudo yum install fop
...
$ a2x -v -f pdf /tmp/test.txt
a2x: failed: cannot find required program: fop.sh

Expected results:
a2x should find all the required tools (without me hunting down for them) and successfully generate /tmp/test.pdf

Additional info:
I haven't experienced this on another F11 machine with exactly the same asciidoc version. I'll have to check if it has fop installed and whether it might have fop.sh in ~/bin/.

Comment 1 Michael Ploujnikov 2009-08-13 13:29:52 UTC
Oops. Forgot to do a search first.

*** This bug has been marked as a duplicate of bug 283351 ***


Note You need to log in before you can comment on or make changes to this bug.