Bug 51738 - creative webcam II do not work
creative webcam II do not work
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-08-14 12:15 EDT by lethalwp
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-06-06 12:58:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
cat /proc/cpia/video0 (3.57 KB, text/plain)
2001-08-14 12:16 EDT, lethalwp
no flags Details
config used for 2.4.8 kernel (26.21 KB, text/plain)
2001-08-14 14:52 EDT, lethalwp
no flags Details

  None (edit)
Description lethalwp 2001-08-14 12:15:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010808

Description of problem:
after loading the cpia_pp, apparently it doesn't "detect" the webcam
correctly? I suspect a bug in the videodev or cpia?

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.have a creative webcam II on parallel port, tried in SPP, ECP, EPP
2.edit modules.conf  add options cpia_pp parport=0
3.load the module (that loads parport && cpia)
4. /proc/cpia/video0 do exist  but you can't access the webcam through

Actual Results:  cat /dev/video0 : No Such Device

Expected Results:  Something else

Additional info:

normally a simple modprobe cpia_pp would have 'detected' the webcam, it
didn't, i had to add the parport=0 as option,  now i have /proc/cpia/video0
present; checking /proc/devices, 81 video_capture is present also,  but cat
/dev/video0  doesn't work;

kernel 2.4.6 compiled with the most standard options of the 'old' 2.4.2 of
rh 7.1.  cpia etc are modules-compiled

here is what dmesg shows me:

Linux video capture interface: v1.00
V4L-Driver for Vision CPiA based cameras v0.7.4
Parallel port driver for Vision CPiA based cameras v0.7.4
0x378: FIFO is 16 bytes
0x378: writeIntrThreshold is 16
0x378: readIntrThreshold is 16
0x378: PWord is 8 bits
0x378: Interrupts are ISA-Pulses
0x378: ECP port cfgA=0x10 cfgB=0x48
0x378: ECP settings irq=7 dma=<none or set by other means>
parport0: PC-style at 0x378 (0x778), irq 7 [PCSPP,TRISTATE,COMPAT,EPP,ECP]
parport0: cpp_daisy: aa5500ff(38)
parport0: assign_addrs: aa5500ff(38)
parport0: cpp_daisy: aa5500ff(38)
parport0: assign_addrs: aa5500ff(38)
usb.c: registered new driver cpia

i've read /usr/src/linux/Documentation/video*/cpia*, even looked through
the .c files after the options or so, but i don't know how i could debug
this more.

if needed: using a tyan motherboard (Trinity 400 - S1854); pIII cpu; it is
based on a via appollo pro 133 chipset

Module                  Size  Used by
cpia_usb                4448   0 (autoclean) (unused)
parport_pc             18416   1 (autoclean)
cpia_pp                 3712   0 (autoclean) (unused)
parport                24896   1 (autoclean) [parport_pc cpia_pp]
cpia                   23664   0 [cpia_usb cpia_pp]
videodev                5088   1 [cpia]
nfs                    76496   1 (autoclean)
binfmt_misc             3552   0
nfsd                   70160   8 (autoclean)
lockd                  50048   1 (autoclean) [nfs nfsd]
sunrpc                 63056   1 (autoclean) [nfs nfsd lockd]
8139too                12544   1
nls_iso8859-1           2880   4 (autoclean)
nls_cp437               4384   3 (autoclean)
vfat                    9424   3 (autoclean)
fat                    32352   0 (autoclean) [vfat]
sb                      7600   1
sb_lib                 34256   0 [sb]
uart401                 6416   0 [sb_lib]
sound             58096   1 [sb_lib uart401]
soundcore               4080   5 [sb_lib sound]
mousedev                4160   1
hid                    11840   0 (unused)
input                   3392   0 [mousedev hid]
usb-uhci               21184   0 (unused)
usbcore                50096   1 [cpia_usb hid usb-uhci]
aic7xxx               108880   7
sd_mod                 11040   6

ps: i now will try with the 2.4.8, but have seen no updates concerning cpia
or videodev, so i'm not really optimistic on that
Comment 1 lethalwp 2001-08-14 12:16:29 EDT
Created attachment 27753 [details]
cat /proc/cpia/video0
Comment 2 lethalwp 2001-08-14 14:52:38 EDT
Created attachment 27793 [details]
config used for 2.4.8 kernel
Comment 3 lethalwp 2001-08-14 14:54:24 EDT
same problem on 2.4.8
this time i think i've tried everything i could think of
Comment 4 lethalwp 2002-04-13 21:17:23 EDT
you can close this "bug" (NOTABUG)

i'm terribly sorry but did a big mistake: i have a webcam 1 not wc2
and have found the sources of windows driver + 2.2kernel, they need to be
adapted to work with kernel 2.4.


Note You need to log in before you can comment on or make changes to this bug.