Bug 517406 - Editing partitions during install can cause them to switch drives
Editing partitions during install can cause them to switch drives
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
high Severity high
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
: Reopened
: 527961 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-13 15:08 EDT by Gary Case
Modified: 2010-07-02 16:40 EDT (History)
4 users (show)

See Also:
Fixed In Version: anaconda-13.21.9-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 16:40:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gary Case 2009-08-13 15:08:31 EDT
Description of problem:
In the drive partitioning section of the installer, you can easily create multiple partitions on multiple drives. If you made a mistake on a partition mount point, for example, and you click on it to change the name, if you don't also re-select the drive where it should live (in the allowable drives section) the partition will move to /dev/sda.

Version-Release number of selected component (if applicable):
RHEL6 alpha

How reproducible:
Every time

Steps to Reproduce:
1. Create a partition on /dev/sdb during install
2. Double-click on partition/Edit it
3. Change the mount point of the partition
4. If you don't select the proper "Allowable Drive", it will default to /dev/sda
  
Actual results:
Moved partition

Expected results:
The edit partition box should maintain the drive selection once it's been made.

Additional info:
Comment 2 RHEL Product and Program Management 2009-08-13 15:37:13 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Chris Lumens 2009-10-08 09:40:08 EDT
*** Bug 527961 has been marked as a duplicate of this bug. ***
Comment 4 David Lehman 2010-01-06 20:56:55 EST

*** This bug has been marked as a duplicate of bug 529931 ***
Comment 5 David Lehman 2010-01-06 20:57:42 EST
I probably shouldn't close RHEL bugs as duplicates of Fedora bugs.
Comment 6 David Lehman 2010-01-06 20:59:10 EST
This should be fixed in anaconda-13.8-1, which should be in the RHEL6 trees in the near future.
Comment 9 Jan Stodola 2010-05-15 10:47:38 EDT
Verified on build RHEL6.0-20100512.0 with anaconda-13.21.39-1.el6. Tested in kvm with two disks, when editing partition, only one allowable drive is selected.

Moving to VERIFIED.
Comment 10 releng-rhel@redhat.com 2010-07-02 16:40:36 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.