Bug 517408 - "Copy to clipboard" does not work
Summary: "Copy to clipboard" does not work
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xfce4-screenshooter
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Christoph Wickert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-13 19:15 UTC by Christoph Wickert
Modified: 2009-11-10 00:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-10 00:52:24 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Xfce 5933 None None None Never

Description Christoph Wickert 2009-08-13 19:15:42 UTC
Description of problem:
taken from bug 478659 comment # 7:
"I'm a newbie running Fedora 11 trying to run xfce4-screenshooter.  Everything
works great except when I select a region with copy to clipboard I am unable to
paste it into OpenOffice Impress like I can with gnome screenshot."

I can confirm Jason's observation, the clipboard does not work at all.

Version-Release number of selected component (if applicable):
xfce4-screenshooter-1.5.1-1.fc11

How reproducible:
always

Steps to Reproduce:
1. run xfce4-screenshooter with "copy to the clipboard":
2. try to insert the content of the clipboard into OpenOffice writer -> nothing happens
3. try to insert the content in GIMP.
  
Actual results:
"GIMP Message
There is no image data in the clipboard to paste."

Expected results:
Content should be pasted into OpenOffice or GIMP

Comment 1 Christoph Wickert 2009-08-13 19:18:51 UTC
Jason, you said the only thing that doesn't work is "Select a Region of the Screen" in combination with "Copy to the Clipboard". For me the clipboard does not work at all. Can you confirm this?

Comment 2 Christoph Wickert 2009-11-10 00:52:24 UTC
Copy to clipboard will only work if
- a clipboard manager is running. parcellite does not work, only xfce4-clipman and the internal one from Gnome are working
and/or
- the screenshooter plugin was added to the panel. It will store the image.

Upstream will make these requirements more obvious. The "copy to clipboard" option will not be available if the requirements are not fulfilled. For more info see http://bugzilla.xfce.org/show_bug.cgi?id=5933


Note You need to log in before you can comment on or make changes to this bug.