Bug 517418 - yum botches computation of needed space
Summary: yum botches computation of needed space
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-13 19:48 UTC by Valdis Kletnieks
Modified: 2014-01-21 23:10 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-28 07:54:44 UTC
Type: ---


Attachments (Terms of Use)

Description Valdis Kletnieks 2009-08-13 19:48:27 UTC
Description of problem:
I go to upgrade several RPMs, and I get this:

--> Finished Dependency Resolution

Dependencies Resolved

========================================================================================================
 Package                                 Arch            Version                 Repository        Size
========================================================================================================
Updating:
 constantine-backgrounds                 noarch          11.90.1-2.fc12          rawhide          5.5 M
 constantine-backgrounds-extras          noarch          11.90.1-2.fc12          rawhide           16 M
 grub                                    x86_64          0.97-58.fc12            rawhide          568 k
 gtk2                                    i686            2.17.7-1.fc12           rawhide          2.8 M
 gtk2                                    x86_64          2.17.7-1.fc12           rawhide          2.8 M
 gtk2-devel                              x86_64          2.17.7-1.fc12           rawhide          1.9 M
 pango                                   i686            1.25.3-1.fc12           rawhide          322 k
 pango                                   x86_64          1.25.3-1.fc12           rawhide          325 k
 pango-devel                             x86_64          1.25.3-1.fc12           rawhide          233 k
 tcl                                     x86_64          1:8.5.7-4.fc12          rawhide          1.8 M
 tcl-devel                               x86_64          1:8.5.7-4.fc12          rawhide          143 k

Transaction Summary
========================================================================================================
Install       0 Package(s)
Upgrade      11 Package(s)

Total size: 32 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
  installing package grub-0.97-58.fc12.x86_64 needs 1KB on the /boot filesystem
  installing package constantine-backgrounds-11.90.1-2.fc12.noarch needs 1KB on the /boot filesystem
  installing package constantine-backgrounds-extras-11.90.1-2.fc12.noarch needs 1KB on the /boot filesystem
  installing package pango-1.25.3-1.fc12.x86_64 needs 1KB on the /boot filesystem
  installing package gtk2-devel-2.17.7-1.fc12.x86_64 needs 1KB on the /boot filesystem
  installing package tcl-devel-1:8.5.7-4.fc12.x86_64 needs 1KB on the /boot filesystem
  installing package gtk2-2.17.7-1.fc12.x86_64 needs 1KB on the /boot filesystem
  installing package gtk2-2.17.7-1.fc12.i686 needs 1KB on the /boot filesystem
  installing package pango-devel-1.25.3-1.fc12.x86_64 needs 1KB on the /boot filesystem

issues: (1) /boot is actually 0% free, grub needs more than 1KB more free space (my fault for it being full, yum's fault for getting the number wrong).  (2) why is this error sticky to the other 8 RPMs (and equally mystifying, why are pango.i686 and pango.x86_64 *not* equally sticky?) - as far as I can tell, grub is the only one of these packages that needs to do *anything* on /boot.


Version-Release number of selected component (if applicable):
yum-3.2.23-13.fc12.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 seth vidal 2009-08-13 19:58:12 UTC
yum doesn't do this space calculation - rpm does. reassigning it.

Comment 2 Panu Matilainen 2009-10-27 09:10:42 UTC
This is more a case of bad reporting and ambiguous messages than miscalculation (although the calculations *are* somewhat off in various circumstances).
1) grub needing just 1KB on /boot means that the new grub package is 1KB larger than the one it's updating, hence it only needs 1KB additional space. This is as intended.
2) The disk space problem reporting is indeed hysterical, as rpm doesn't even try to figure whether a given package wants to install something on a filesystem which already got full, so once a problem on a filesystem is encountered, it gets repeated for all the remaining packages in the transaction. This is now fixed upstream.

Comment 3 Panu Matilainen 2009-10-28 07:54:44 UTC
Fixed in rawhide / rpm-4.7.1-8.fc13

Comment 4 Panu Matilainen 2009-10-28 07:55:25 UTC
Err, s/NOTABUG/RAWHIDE/


Note You need to log in before you can comment on or make changes to this bug.