Bug 517431 - ldap is not configured during install
ldap is not configured during install
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: authconfig (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-13 17:37 EDT by Orion Poplawski
Modified: 2009-08-14 16:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-14 16:15:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2009-08-13 17:37:09 EDT
Description of problem:

kickstart install with:

authconfig --enablemd5 --enableshadow --enableldap --enableldapauth --ldapserver=ldap.cora.nwra.com --ldapbasedn=dc=nwra,dc=com --enableldaptls --ldaploadcacert=http://www.cora.nwra.com/cgi-bin/getca.pl --enablecache

program.log simply shows:

Running... ['/usr/sbin/authconfig', '--update', '--nostart', '--enablemd5', '--enableshadow', '--enableldap', '--enableldapauth', '--ldapserver=ldap.cora.nwra.com', '--ldapbasedn=dc=nwra,dc=com', '--enableldaptls', '--ldaploadcacert=http://www.cora.nwra.com/cgi-bin/getca.pl', '--enablecache']

but after install /etc/ldap.conf is not configured.  I can run the authconfig command by hand after install and it works and ldap is configured.

Version-Release number of selected component (if applicable):
12.14

I see records in the webserver logs for retrieving the CA cert.
Comment 1 Andy Lindeberg 2009-08-14 10:38:36 EDT
Anaconda seems to be doing what it should here.

Sending to authconfig - has there been any recent change in ldap support, or do you see any apparent user error?
Comment 2 Chris Lumens 2009-08-14 10:42:06 EDT
Did you do a network install?  If there's no network enabled, I can see how authconfig might fail with trying to contact the ldap server.  When you say that you ran the command after install, did you run it from tty2 while anaconda was sitting on the completion screen or did you reboot?  If the latter, could you try the former?
Comment 3 Orion Poplawski 2009-08-14 16:15:54 EDT
Hmm, must have been a one time fluke.  Works now.  Sorry about that.

Note You need to log in before you can comment on or make changes to this bug.