Bug 517482 - crashes on "clear all"
Summary: crashes on "clear all"
Keywords:
Status: CLOSED DUPLICATE of bug 448467
Alias: None
Product: Fedora
Classification: Fedora
Component: octave
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Rakesh Pandit
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-14 09:48 UTC by Chitlesh GOORAH
Modified: 2009-08-14 14:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-14 14:31:24 UTC


Attachments (Terms of Use)
dumped filed created when crashed (50 bytes, application/octet-stream)
2009-08-14 09:49 UTC, Chitlesh GOORAH
no flags Details

Description Chitlesh GOORAH 2009-08-14 09:48:25 UTC
Description of problem:
octave crashes if typed "clear all"

Version-Release number of selected component (if applicable):
octave-3.0.5-1.fc11.i586

How reproducible:
Everytime

Steps to Reproduce:
1. octave
2. clear all
3.
  
Actual results:
panic: Segmentation fault -- stopping myself...
attempting to save variables to `octave-core'...
save to `octave-core' complete
Segmentation fault



Expected results:
clear all as matlab would do

Additional info:

This is blocker for large projects which are migrating from matlab to octave.

Comment 1 Chitlesh GOORAH 2009-08-14 09:49:17 UTC
Created attachment 357416 [details]
dumped filed created when crashed

Comment 2 Alex Lancaster 2009-08-14 14:28:39 UTC
Do you also have octave-forge installed?  There's a good chance this is a dupe of bug #448467.  There are two particular SWIG-built packages that can cause this.

Comment 3 Alex Lancaster 2009-08-14 14:31:24 UTC
Yep, I can duplicate this if octave-forge is installed and it goes away if octave-forge is removed.

*** This bug has been marked as a duplicate of bug 448467 ***


Note You need to log in before you can comment on or make changes to this bug.